Stack Exchange Network

Stack Exchange network consists of 175 Q&A communities including Stack Overflow, the largest, most trusted online community for developers to learn, share their knowledge, and build their careers.

Visit Stack Exchange

Questions tagged [usbasp]

The tag has no usage guidance.

0
votes
1answer
39 views

Usbasp Arduino Uno Bootloader Flash Error - Win 10

I'm trying to flash an Arduino Uno using usbasp but i'm getting the following error,I have checked all the connection and voltage using multimeter but still this error: Arduino: 1.8.8 (Windows 10), ...
0
votes
0answers
18 views

how to fix USBASP Unknown USB Device (device descriptor request failed) - Win 10?

I just recently purchased Usbasp from Ali Express, when i'm connecting it to the windows 10 desktop in device manager its Unknown USB Device (device descriptor request failed). How to fix this error? ...
0
votes
1answer
18 views

AVRDUDE crashes when trying to use TPI [on hold]

I've been having this issue where avrdude crashes when trying to upload through a usbasp (with current firmware) to an attiny10. Used to work consistently but now it just crashes consistently, weird ...
1
vote
1answer
33 views

Transmit image file thougth the TX TR serial line

I have a digital camera with a USB port for image dowload from the camera SD card. I will like to be able to capture this image files store in the camera SD card using the Arduino TX TR lines (...
1
vote
0answers
49 views

Atmega 32U4 doesn't show on device manager after fuse bits reset

I am finally ready to try setting fuse bits on my ATMega32u4-AU custom board (8Mhz Ceramic Resonators, 3.3V), however, after I set the fuse bits and plug my board to computer, the device manager ...
1
vote
1answer
175 views

ATmega328P of Arduino Pro Mini not responding

While I was trying to change the fuse bits of ATmega328P of my Arduino pro mini using a USBasp device to operate it at 3.3 V/8 MHz, it failed due to the bad connection I guess. After that, ...
1
vote
0answers
574 views

Arduino nano stk500_getsync() attempt 1 of 10: not in sync: resp=0xe1

I have been building a project using an arduino nano clone. It uses the CH340 chip. It worked perfectly, and a week later it now doesnt. When I want to upload code in arduino IDE I get the error ...
1
vote
0answers
69 views

Can I upload with avrdude 2 hexes with 2 usbasp connected to computer, one hex with one usbasp ? If yes, how?

If I have connected 2 usbasps in the same time to ubuntu, can I upload 2 hexes one after the other(using avrdude) on each usbasp without disconnecting a usbasp ? If yes, how do I select each port for ...
0
votes
1answer
518 views

Can i burn an Arduino sketch .hex directly using USBASP?

I am unable to upload sketches to my Arduino Uno board using the upload option in the IDE. I have done quite a few tests to find the reason but everything seems to be working fine when tested ...
0
votes
2answers
2k views

How to flash an ATmega directly without a dedicated flashing device?

An ATmega microcontroller can be flashed by a C compiler and a USB dedicated device (ISP). I tried to flash the program into the microcontroller by saving the machine code to a MicroSD card that I ...
1
vote
1answer
426 views

Arduino pro mini (clone) @1Mhz target does not answer

Recently I have been experimenting with battery powered sensor (mySensors). I created node with 3.3V Arduino Pro Mini (ATMega328P @ 8Mhz with nordic radio chip and BME280 sensor) and successfully ...
0
votes
1answer
1k views

Help with usbasp pinout

I am having trouble figuring out the pinout of my 6 - pin USBasp Chinese clone that I got off eBay. BEFORE YOU TELL ME TO LOOK AT THE PINOUT DIAGRAMS, I can tell you that my version of the usbasp has ...