0

I bought the standard 1.77" TFT screen months ago and It has never worked. I follow the wiring diagram shown for Uno on the guide on the Arduino website and the best result I have ever got is it seeming like the screen itself is broken. I must have rewired the whole thing many times now and quadruple checked each time. As I have never used this screen before I do not know what is correct any further than the tutorial.

enter image description here

I say that because it seems to understand instructions but does not display them correctly.
I have tried multiple examples and tests on it that all yield weird results.
The tests I have tried are:

  • The SD demo that loads the Arduino icon off SD and fills the screen with it. The serial connection says that it has successfully read the image but just displays black lines
  • Setting the background colour with random colours which seems to work fine apart from the black bars
  • Drawing random colour, positioned and sized rectangles. Result is image below. Colours seems to prefer pink, purple and white.

Random rectangles test

As you can see it looks like the image is 1D, no rectangles stop across the x axis so I did a test for that, it just draws a 1x1 pixel red dot going down the screen's left side, if it drew a red line moving down then my thought that it was stretching the first column would be correct, it didn't, just white and black bars still, so I modified it to test every column in case it wasn't column 0, same result...weirdly only when I made the 1x1px rectangle 5x5 my idea was correct.

Another completely different test looks the same> Black lines not changed

As you can see on both the images, the black bars are a persistent factor, their colour cannot be changed and they appear once TFT.begin has been called.

After looking around the only help I could find is someone mentioned that Arduino the company updated the TFT library but not the software but he/she didn't provide a download link. In the time I've had this I'm sure I'm redownloaded/updated the Arduino software a few times too.

Are the glitches normal for wrong pin connections? Is there some pin wrong on the website?

  • A wrong library is not likely to cause that, it sure looks broken to me. – Jasmine Nov 19 '14 at 23:15
  • Maybe post a photo of your wiring... the screen output isn't real helpful. – Jasmine Nov 19 '14 at 23:21
  • @Jasmine TLDR? That's the last thing I thought I'd hear with how how much information I put in. I did say I'm sure the wiring is correct but I'll upload a picture anyway. – user4892 Nov 20 '14 at 16:26
  • It's good information, but the screen shots don't give any clue to the problem other than "it's not right" and the wiring for these isn't super simple, and I have seen similar displays with wrong wiring, but it also seems your data is getting through. So, I want to check the wiring before stating the screen is broken with any real certainty. – Jasmine Nov 20 '14 at 16:49
  • @Jasmine Added wiring. – user4892 Nov 20 '14 at 17:30
-1

It's pretty hard to see the wiring for sure in the photo, but you have an extra red wire looped from one side to the other, what is that for? It's not in the tutorial. Other than that, your wiring looks ok to me, as far as I can see from the photo. So probably it's broken, I hope you can return it.

  • The extra red wire is for the backlight. Unfortunately I was so determined to test it in so many way by so many people it took too long so I highly doubt anyone would allow a return after months. – user4892 Nov 20 '14 at 18:46
  • OH! You have a simple solution then. Buy another one and use it right away. If the same thing happens, your wiring is wrong and you have two good boards. If the new one works, you know this one is bad. – Jasmine Nov 20 '14 at 20:27
-1

I ran into the same problem, looked around the net a bit. Someone found a solution from the Italian forums translated + posted how to help this.

In short there was something wrong with the TFT library https://forums.adafruit.com/viewtopic.php?f=25&t=45289#p228908

I installed the nightly build, currently 1.6.0 and the screen is working now.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy