So I'm following a beginners arduino book and I made a blinking program and now I've coded another program but when I try to upload it, avrdude(whatever that is) gives me the errors in the title and repeats them 10 times. I have tried this so far:

  • Restarting my windows 8
  • Pressing the reset button on my arduino uno R3

My guess is that since it worked the first time, my blinking program must be clogging up the space in my arduino.How can I fix this problem. Or if my guess is right, how can I get the blinking program out of arduino and go home to my bots folder?

My IDE is arduino 1.6.7 and my port is CPU1. and lots of people mention tools>serial port but there isn't a "serial port" button on my IDE.


I had the same exact problem and fixed it, just by molding the two reset pins on the arduino together. Just check if they are properly connected as the error probably is caused by that.

enter image description here

If that doesn't work, check the LEDs on the board. When you are uploading a sketch both RX and TX should be lightning up.

  • There is a gap between my reset pins. How do I mold them together?
    – Max
    Dec 26 '15 at 10:42

Since there are no accepted or up-voted answers to this rather old question I'm going to link to my post here about problems with uploading.


Just search a little bit around Google.

A simple solution is pressing the restart button after the program is compiled, then, upload it.

Or restart the Arduino while the Arduino is uploading the program.

If the problem remains, try to burn again the bootloader of your arduino.

  • "Searching around a little bit arround on google" is not particularly helpful, as googling is probably what led the OP to SE in the first place! ;-) If you could provide a useful link or two (which you have done), along with a quoted summary of the info provided in each link (in the case of future link death) that would be great, or better still, if you have encountered this issue yourself, feel free to provide your own solution (which you also have done)... :-) Dec 30 '15 at 5:48

You're probably trying to connect through the wrong port.

I had this problem due to the mac suddenly making the /dev/cu.USB port option unavailable for selection through the arduino software interface under tools/port, and then not knowing what I was doing I just tried to connect through the wrong port and got this error.

After rebooted the mac, voila the /dev/cu.USB port option was suddenly available again under tools/port, we selected it and were able to successfully upload again.

I don't know why the mac or arduino software does this, my sense is that something must get confused during upload sometimes, especially if you disconnect and reconnect the usb for some reasons, or turn on the 9v power on the arduino board while uploading.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.