2

I had mistakenly burnt my ATmega328p that was there on the Arduino UNO R3 board. So I bought a new ATmega328p-pu with Arduino UNO bootloader installed and a sample blinking LED program pre-flashed.

However when I replaced it and plugged in to the PC using the provided Arduino programmer cable, I could not find the COM port in the device manager in Windows and neither in the Arduino IDE.

I should also mention that when I put the new Atmega328p-pu into the Arduino UNO board, the LED at 13 or L did start blinking. So I am inclined to think that both the bootloader and the sample program are there. But I cannot find the required COM port.

How do I fix this?

  • 3
    you should see the com port on the computer even without a chip. try rebooting. – dandavis Jun 13 '17 at 14:58
  • 6
    Maybe the ATMega328P-PU isn't the only chip you blew up...? – Majenko Jun 13 '17 at 15:00
  • @dandavis I could see the COM port in the device manager as a hidden device but it wasn't "active". – Ris97 Jun 14 '17 at 3:29
  • I agree with @Majenko. Think of all the connections on the board, and the current path it would take to fry the CPU. It must have gone through other components on the way. Might be time to try another board to eliminate the possibility of it being a bad cable or a computer software problem. . – SDsolar Jun 14 '17 at 10:48
  • Alright I might have fried the some other component on the board. I'll try something else. Thank you all for your replies. – Ris97 Jun 14 '17 at 14:07
1

Generally the IDE will detect one it can use, so you shouldn't need to use the Device Manager.

When you select the board type, so far, so good.

Then when you ask it to pick the port, it will present a list of ports that it has discovered that are registered in the Device Manager.

One thing you will notice is that if you have a Genuine Uno, for instance, it will list that next to the port name.

But if you are using a board (of any type) that have the CH340-type port it will show just the COM9 or whatever it finds.

If it doesn't find any ports (My laptop always detects the COM1 port on the back that I never use so in my case if that is all it finds then it is not finding any USB ports) then jump ahead to the arrow below.

So by trying each one you will find a port that works with your board. Or not.

I am sure you have already seen the errors it throws when you use a port that won't work for you.

-----> If you have tried all the ports listed and none works, then you are left with only a couple of possibilities: Either the cable is bad, or the board is not responding.

Ultimately, it doesn't matter what it says in Device Manager if the IDE won't use it.

So if you can find another board and see if the cable works that would eliminate the cable as being a problem.

But if it simply will not respond then look above in the comments at what @Majenko said.

Good luck.

  • Just a heads-up, this answer has been flagged as low quality. You might want to do something about it and expand upon your answer, before it gets deleted. It is rather terse, as it stands, tbh. – Greenonline Jun 14 '17 at 6:10
  • Thank you, @Greenonline. I was tired and at the end of my work day when I posted that. I agree that if I was reviewing it I would at the very least have said that it looks more like a comment. I really appreciate the heads-up. I hope this is better. I know for sure that it works like this because I have had a bad cable that made me doubt brand-new Nanos. I put three of them in the ? box before I decided to change cables and Amazing Grace they all worked. TNX again. Have a great day! – SDsolar Jun 14 '17 at 10:44
  • I met her once. She wasn't that amazing... – Majenko Jun 14 '17 at 10:50
  • Heh, heh! ;-) That's pretty funny. – SDsolar Jun 14 '17 at 10:53

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.