2

I'm getting the following error with a genuine Arduino Uno on Mac OSX10.11 El Capitan when uploading to it (the green light is on, the orange light flashes intermittently while attempting to upload). Here's the error:

avrdude: stk500_recv(): programmer is not responding

I've tried all the solutions I can find. I've selected the correct port and board. I've tried pressing the reset button before uploading. I've tried different USB cables. I've tried unplugging and replugging everything. I've read this: http://arduino.cc/en/Guide/Howto .

I tried all these solutions here: https://stackoverflow.com/questions/23993111/mac-uno-avrdude-stk500-recv-programmer-is-not-responding

I tried the FTDI fix, (but not sure if was actually able to disable the mac drivers, or which drivers are now running, the example I tried is for for OSX 10.10 Here). I ran into the following issue in the Terminal:

Mac-Pro:~ m$ cd /System/Library/Extensions/IOUSBFamily.kext/Contents/PlugIns
Mac-Pro:PlugIns m$ sudo mv AppleUSBFTDI.kext AppleUSBFTDI.disabled
mv: rename AppleUSBFTDI.kext to AppleUSBFTDI.disabled: No such file or directory

I don't get why it says No such file or directory because AppleUSBFTDI.kext definitely exists as a package in the Extensions folder, but I guess it's talking about another file named that in the plugins folder? Confusing ... Was this moved in OSX 10.11 and should I rename this package in the Extensions folder?

I did download and install the old FTDI drivers, but I don't know if they're actually the ones working right now? How do I clarify that?

Any ideas how to get this working?

I also tried on an old Mac Laptop 10.6.8 - Snow Leopard, and had the same issue :(

2

Has this ever worked? Can you use avrdude and hit the target?
There is a terminal mode in avrdude you can also use. At least this would help you determine what is working.

Sounds like a configuration issue. If you have the ability to 'follow the tail' (tail -f ) I'm assuming that you have 'like' tools we have in Linux like lsusb to assist?

You can ensure yourself that if it says it isn't found, it's not finding it, so it's not wherever it's looking. :)

  • It had never worked. I think it was just a bad one, I got a new one, works perfectly :D – Agent Zebra Feb 19 '17 at 4:41
1

I had this problem for some time and what I did was I deleted the Arduino IDE and reinstalled it again and it worked. Thanks!

0

Nothing I tried could get it to work. I took it back on the hunch it was a bad one, that something was just not working right on it. And got a new one directly from the Arduino people. The new one works just fine! Problem solved :D

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.