0

I just bought the SmartEverything FOX Board which is Arduino compatible http://www.smarteverything.it/wp-content/uploads/2015/10/SmartEverything-User-Guide-Ver-1.01.pdf and simply tried to get started with it.

My OS is Ubuntu 14.04, my laptop DELL XPS 13 bought in 2014

I cannot upload sketches on it, when I try, it gets stuck on uploading, whether it is a basic script (blinkRBG) or even the default one with empty setup and loop methods, my laptop processor keeps running at 100% and nothing happens. The board does not do anything, tx/rx leds do not flash. I can access to it with a Windows 7 laptop (UPDATE: and another UBUNTU laptop) from a friend, I could upload the basic blinkRGB sketch. If I try to upload from my Ubuntu laptop after, it does erase the contents and stop the blinking but nothing follows.

When I try to upload, I only get the compiling logs: Quote

Sketch uses 13,368 bytes (5%) of program storage space. Maximum is 262,144 bytes.

I could still upload sketches to another board from my Ubuntu laptop: to an Arduino micro.

I am connecting directly from my board to my laptop through USB 3.0, I don't have USB2.0 plugs on my laptop, and I currently don't have any programmer device.

I tried with different versions of arduino IDE (1.6.4 1.6.5 nightly), same issue every time. The IDE sees that my board is connected on /dev/ttyACM0

I tried to run in command line but it gets stuck as well Quote /home/jcharlet/.arduino15/packages/arduino/tools/bossac/1.6-arduino/bossac --port=ttyACM0

I've been googling the world but could not find anything, could anyone help me to troubleshoot it please?

  • 1
    Have you added yourself to the dialout group? $ sudo usermod -a -G dialout jcharlet then log out and log in again or reboot. – Majenko Oct 10 '15 at 11:21
  • thank you Majenko for your answer, but I already tried it, and it did not work. – Jeremie Oct 20 '15 at 10:42
  • Enable verbose upload log from the IDE's settings. – Avamander Jan 22 '16 at 22:05
0

Moved to another board more suitable to our needs, but @sm4rteverything (Twitter) gave us the following solution (not tested):

This is a known bug of the bootloader.

to fix this U need to download the one i attach in this email with the ATMEL-ICE tool. http://www.atmel.com/tools/atatmel-ice.aspx

Copy the attched file under: \Arduino15\packages\AMEL\hardware\samd\1.0.0\bootloaders\sme (Linux) C:\Users\\AppData\Roaming\Arduino15\packages\AMEL\hardware\samd\1.0.0\bootloaders\sme (Windows)

last follow these three simple step Connect the ATMEL-ICE on the SWD J1 connector (pin 1 on top-rigth , the pin on eon cabel is the red one)

Board picture

select on Arduino IDE to connect to ASME via atmel-ice (board menu) tool->burn bootloader

  • Please clarify if your answer indicates a solution to the problem. If so, please accept it by clicking on the "tick" icon next to the answer. This indicates to other users that the answer is useful, and it also stops Stack Exchange from periodically "bumping" your question in the hope of getting an accepted answer. Thanks for your understanding and cooperation! – Nick Gammon Jan 23 '16 at 3:41
  • marked as solved – Jeremie Jan 26 '16 at 17:33

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.