0

I'd like to say that I'm a noob at both Arduino & Ubuntu (have some command line experience).

I've set port permissions, joined the relevant groups (tty,uucp,dialout & plugdev). I know that the IDE recognizes the board because ttyACM0 only shows up when the board is plugged in. I've searched the Internet and Stack Exchange and Arduino troubleshooting guide and tried all the suggestions. It's not Genuino but a knock-off that's recognized as an Uno. I've got to be missing something.

Are there any relevant logs or a way to monitor whats going on in realtime?

Verbose upload output:

Arduino: 1.8.5 (Linux), Board: "Arduino/Genuino Uno"

Sketch uses 928 bytes (2%) of program storage space. Maximum is 32256 bytes.
Global variables use 9 bytes (0%) of dynamic memory, leaving 2039 bytes for local variables. Maximum is 2048 bytes.
/snap/arduino-mhall119/5/hardware/tools/avr/bin/avrdude -C/snap/arduino-mhall119/5/hardware/tools/avr/etc/avrdude.conf -v -patmega328p -carduino -P/dev/ttyACM0 -b115200 -D -Uflash:w:/tmp/arduino_build_241052/Blink500.ino.hex:i 

avrdude: Version 6.3, compiled on Jan 17 2017 at 11:00:16
         Copyright (c) 2000-2005 Brian Dean, http://www.bdmicro.com/
         Copyright (c) 2007-2014 Joerg Wunsch

         System wide configuration file is "/snap/arduino-mhall119/5/hardware/tools/avr/etc/avrdude.conf"
         User configuration file is "/home/harry/snap/arduino-mhall119/5/.avrduderc"
         User configuration file does not exist or is not a regular file, skipping

         Using Port                    : /dev/ttyACM0
         Using Programmer              : arduino
         Overriding Baud Rate          : 115200
avrdude: ser_open(): can't open device "/dev/ttyACM0": Permission denied

avrdude done.  Thank you.

Problem uploading to board.  See http://www.arduino.cc/en/Guide/Troubleshooting#upload for suggestions.

This report would have more information with
"Show verbose output during compilation"
option enabled in File -> Preferences.
  • 1
    "and tried all the suggestions". It would be helpful if you listed what you've tried. Did you do this: arduino.cc/en/Guide/Linux#toc6 – per1234 Dec 30 '18 at 2:26
  • Yes I did try that however I'll try it again. I know what port I'm trying to access and I set the permissions for it, I've made sure I'm in all the groups required. I've been at this for 2 days. I've tried installing packages from Ubuntu and Arduino. I could edit my bash history for redundancy and post that if it would be helpful. I've created a rules file (I don't remember the exact path, I could look it up). Thank you for your suggestion, I appreciate it – Harry Busk Dec 30 '18 at 2:39
  • Please do this: File > Preferences > Show verbose output during: > compilation (uncheck) > upload (check). After the upload fails you'll see a button on the right side of the orange bar "Copy error messages". Click that button. Edit your question and paste the error messages in a code block ({} button on the toolbar). – per1234 Dec 30 '18 at 2:48
  • 1
    That is confusing. You installed "arduino-mhall119" version 1.8.5 size 158MB from the snap. There is another snap "Arduino IDE" also version 1.8.5 size 445MB (a lot larger). In the repositories is "arduino", "arduino-core" and so on, I think version 1.05. I don't use any of those. Harry Busk, can you try to remove the snap version and every arduino related thing from the repositories and download the 64-bit linux version 1.8.8 : arduino.cc/en/Main/Software Unpack it under your home folder and make a shortcut to the 'arduino' file and try that. – Jot Dec 30 '18 at 4:36
  • Hello jet, thank you for your suggestion. I'm using a 32-bit laptop. Will the 64-bit version still work? – Harry Busk Dec 30 '18 at 4:47
0

As stupid as it may sound but "have you tried turning it off and on again?". Changes to groups only become effective when you have logged out of your account

  • LOL, yes I tried that. I was advised of that several times during my searches. There are no stupid suggestions, I really appreciate your input. – Harry Busk Dec 30 '18 at 9:38
  • Just one more thing: are you sure ttyAMC0 is the correct port? On my ubuntu machine its ttyUSB0 – user2912328 Dec 30 '18 at 9:41
  • I really believe so. When the board is unplugged my IDE shows only ttyS0. Plugging the board in causes ttyAMC0 to appear – Harry Busk Dec 30 '18 at 9:45

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.