2

I recently bought an Arduino Micro to see what all the fuss was about and I figured I'd use it with Ubuntu on an older Dell Latitude. I was able to install all of the files using some tutorials but I have this problem uploading sketches. After plugging in the board, the green top LED is consistently flashing so it seems to be working, but when I try to upload a sketch I get the following error

Connecting to programmer: .avrdude: Send: . [1b] 
avrdude: Send: S [53] 
avrdude: ser_recv(): programmer is not responding
avrdude: butterfly_recv(): programmer is not responding

Any ideas how to fix this? I tried pressing reset during the send as some forums have suggested but it doesnt seem to be working.

  • I just successfully compiled and uploaded the blink sketch to a Mega on 14.04, so the update shouldn't be an issue. Are you using the correct serial interface and board type? – jippie May 2 '14 at 20:28
  • Unplug Arduino; type sudo dmesg -c; clear. Plug in Arduino, wait a couple seconds, then type dmesg and copy the output into your question. Also add the output for lsusb to your question. – jippie May 2 '14 at 21:07
  • @jippie how do you determine the correct serial interface? – user3495252 May 4 '14 at 15:46
  • It is in the dmesg output that you get when following above hint. – jippie May 4 '14 at 15:50
  • @jippie thanks for helping. not near the board at this time but i'll try and comment in a bit – user3495252 May 4 '14 at 15:59
2

I have a Micro and Ubuntu 14.04. I have successfully uploaded sketches to the Micro using IDE 1.0.6. Thus that combination should work.

I suggest you get the sketch compiling OK. Then hold down the Reset button on the Micro, start an upload with your other hand, and release Reset when it says "Uploading".


Try typing

lsusb | grep Arduino

I found with a sketch uploaded which opens the Serial port:

Bus 003 Device 087: ID 2341:8037 Arduino SA

If you hit Reset and wait a second, then do the lsusb again you see a different device:

Bus 003 Device 086: ID 2341:0036 Arduino SA

That one (the 0036 one) is the one it will upload to. You might get 0037 rather than 0036 because I reflashed the bootloader to be the Leonardo one, but the concept is the same.

0

The only way I have been able to fix this is revert back to Ubuntu 12.04.

There is something about 14.04 that does not play nice with the Micro.

I've tried running avrdude on the command line as well with no luck. The Arduino IDE code jumps through some hoops to detect the proper USB port, so timing is probably critical. I don't know the secret sauce for 14.04 though. The micro is tricky since USB is disconnected and reconnected during programming.

If anybody has better luck with this please update.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.