1

NOTE: Using the Arduino Uno

I am WORKING on a project that I have to submit in a few days. My arduino was all set up and was working fine.

Project:Arduino controls a 9v motor depending on the command given. As the arduino only provides 5v , i added a 9v battery to it through a transistor

I decided to add new code into the arduino but when I tried it failed. I have uploaded code thousands of times before (successfully) all of a sudden the IDE keeps giving the following message

avrdude: ser_open(): can't open device "\.\COM3": Access is denied.

I have looked up for a lot of solutions on this forum and elsewhere. Here are the things I have tried so far:

  1. Changing the COM port
  2. Disabling all the other devices CONNECTED to COM
  3. Tightening the CONNECTIONS
  4. Re installing all the drivers and the IDE
  5. Rebooting the system
  6. Using another laptop to upload code

All the above have given me the same output for some reason. The built in LED light and the power LED switch on when the board is CONNECTED to a power source (my laptop). Could the board have been damaged by any chance ? How can I check if the board is spoilt ? Should I buy a new board ?

  • Have you tried this on another computer? – Anonymous Penguin Apr 11 '15 at 13:23
  • @AnnonomusPenguin yes – user4417613 Apr 11 '15 at 13:26
  • @AnnonomusPenguin I get the same error – user4417613 Apr 11 '15 at 13:26
  • 1
    Well, either your board is fried or you keep making the same mistake when installing the drivers on all of the computers. Have you tried reinstalling the Arduino bootloader, also? – Anonymous Penguin Apr 11 '15 at 13:28
  • According to this solution: instructables.com/id/… You may use your board instead of Lilypad on the link above, to program your board, you may make a connection the same in URL above. I guess this will solve your problem. – Bay Dec 9 '15 at 18:30
2

I have a post Have I bricked my Arduino Uno? Problems with uploading to board - that describes various tests you can carry out to isolate where the problem is.

1

Have you tried changing the Microprocessor in the Arduino Uno? An AtMega320P is much cheaper than new Arduino, and usually only the microprocessor gets spoilt, rest of the board remains intact.

1

Could be the OS not allowing the application to access the COM ports, there is a terminal command to give the Arduino IDE access to the specific COM port.

0
  1. Remove all device connect to uno, and upload code to uno. Because, your device like motor will confuse uno.
  2. Check you usb to serial device.
  3. Check your uno
  • All the connections are removed . Still does not work – user4417613 Apr 11 '15 at 9:27
  • How do I check if the uno is spoilt – user4417613 Apr 11 '15 at 9:27
  • Maybe change a uno? I meet the same stage when I try to connect a motor to micro pro. I fixed that by change a micro pro. – SivaCoHan Apr 11 '15 at 9:30
  • So basically I need to buy a new one? – user4417613 Apr 11 '15 at 9:31
  • yeah, I think so. – SivaCoHan Apr 11 '15 at 9:31
0

Check the device that the IDE says you're connected to.

http://forum.arduino.cc/index.php?topic=51489.0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.