I've been trying to get my nodemcu working for months and tried countless online references but none worked. I'm using the Arduino IDE to upload sketches and always get the error "Timed out waiting for packer header"

Here's my setup. I'm trying to upload the example blink code for the nodemcu 1.0 12E.

Screenshot of arduino IDE

My board does show up on device manager and here's proof.

got the drivers for the board

When i press reset on the nodemcu and have the serial monitor on at 74880 baud the board spits out this. serial monitor output

I have tried pressing the reset and flash buttons while uploading in the desired sequence but that didn't work. I even went as far as reflashing the firmware through the nodemcu flasher but it's always stuck at waiting for MAC and STA address.

Please help me fix the problem and i'm sure not the only one facing this issue. Hoping for help :).

  • You must not have the serial monitor open while programming the board. The response from the board ends up going to the serial monitor instead of to the esptool.py process that's doing the programming.
    – Majenko
    Oct 22 '20 at 13:33
  • no lol i never have the serial monitor open while i try to upload. i put the screen grab just to show the nodemcu can talk back .
    – Ted Mosby
    Oct 22 '20 at 13:37
  • Ok. Try selecting a different "Upload Speed" in the Tools menu.
    – Majenko
    Oct 22 '20 at 13:39
  • 1
    um tried all , still nothing unfortunatley
    – Ted Mosby
    Oct 22 '20 at 14:03
  • did you try to put the mcu in bootloader mode manually? holding the flash button while resetting with the reset button?
    – Juraj
    Oct 22 '20 at 16:33

Turns out it was a board problem. Switched it for an older version of the NodeMCU.

The newer ones are not known for the reliability it seems.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.