0

After programming Arduino Nano with the DIY Headtracker code, after trying to plug the Arduino to the receiver and some time, the LED stops flashing and now it's not recognized by the computer anymore.

When I plug it, it only lights the power LED.

The worst thing is that I've already tried with another Nano and it bricked also, can't use them any more. Anyone know any fix to this?

This is the error given when trying to upload the blink sketch to the board...

avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 1 of 10: not in sync: resp=0xb8
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 2 of 10: not in sync: resp=0xb8
avrdude: stk500_recv(): programmer is not responding
1

I suggest you visit the page Have I bricked my Arduino Uno? - whilst you have a Nano and not a Uno, it is the same processor and most of the remarks there will apply.

As the Arduino Nano page says:

It has more or less the same functionality of the Arduino Duemilanove, but in a different package.

If you have another Uno or similar lying around you could conduct the "chip detector" test described on that page. You could also perform the loopback test.

It is possible on the FTDI chip (underneath) is damaged in which case there would be alternatives to using that.

0

If you have access to an AVR ICE MKII or an AVRDragon, you could try High Voltage programming. It is, AFAIK, the ultimate way to revive a bricked device. There might be some alternative method to perform HV programming without any of the devices I mentioned (for example with another AVR), but I'm not aware of it, if it exists.

  • 1
    It's not really practical with a chip soldered to the board to do high-voltage programming, because you would send 12 V via the /RESET pull-up resistor to the +5 V pins, which would damage the chip. – Nick Gammon Jul 22 '15 at 0:01
  • @NickGammon: I wonder if there is any relatively simple way to cut a track or two and place jumpers on them. A bit like the procedure to make USB-reset optional for the UNO when enabling debugWire. First thing that comes to my mind is to desolder the pullup, use the pads to wire/solder a male pin header and attach the resistor to a female pin header. – Igor Stoppa Jul 22 '15 at 6:05
  • If was desperate, I would consider doing that. The other thing is that you have a whole lot of wires to connect (as the chip is soldered in). I've got a post about high-voltage programming which shows that you have around 20 wires to connect. I'd be a little surprised if it came to that. Either the chip has been hopelessly damaged, or you can recover with ICSP programming. – Nick Gammon Jul 22 '15 at 6:39
  • @NickGammon the 12v is going through a 1k resistor. The 5v would rise by no more than a volt. Now for the math (correct me if I'm wrong); The 328 uses at least 5mA (5v @8Mhz), which is equivalent to a 1k resistor (R=V/I). So together with the 1k on the reset line, it would create a voltage divider, giving 6v at the VCC point. 6v is just with the maximum ratings. If there is anything else in the circuit using current, it would be even lower than 6v. Or just add a 2.5k resistor between vcc and gnd to get exactly 5v. Pretty interesting point you made. Quite a brain-breaker to figure out. – Gerben Jul 22 '15 at 8:30
  • Yes, that might work. I think I like the idea of the 2.5 k resistor in case the processor uses less power at some point. Indeed, the fluctuations in power during programming mode (if there are any) might be amplified by this 12 V effect. You also would need to solder onto XTAL1 which is not broken out to a pin. Again, though, I would try ICSP programming first. Much simpler to do, and there is no real proof at this stage that whatever-it-is that is wrong could be fixed by high-voltage programming but not ICSP programming. – Nick Gammon Jul 22 '15 at 20:55
0

https://www.sparkfun.com/news/1629 Maybe your windows update has installed new drivers for your FTDI chip. You can check that your usb device PID is set to 0x0000

(You probably have the "Gravitech Nano V3.0" (with FTDI chip on the back)? I have, and this worked for me.)

In this case, you should download M_PROG from FTDI And then check for the chip, when found, you set the PID to FTDI default (0x6001). Then simply press program, and it will re-set your device PID.

Also, you should download the "CDM-v2.12.00-WHQL-Certified.zip" drivers. Another source

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.