0

My arduino cannot connect to any port of my computer. So far i tried the following, without any luck:

  1. Using another arduino to check the usb, and it worked. So no problem with usb cable.
  2. Resetting the arduino (double tap the reset-button)
  3. Inserting deleting and updating the drivers from the device manager
  4. Deleting the drivers, and then inserting the arduino while pressing the reset button.
  5. Connecting the arduino to a different pc and it still doesn't work.
  6. I followed everything listed here. (Resetting, uploading a uf2 blink file). I even compiled my blink uf2 file, with the newest version of mbed os for rp2040. And i even tried with older versions of the mbed os.
  7. I tried uploading a flash_nuke.uf2 file

Is there something else i can do? Or is it permenantly damaged?

When i connect to to the computer, this comes up: enter image description here

In my device manager, i see the following:

Another

Also, in the IDE, i cannot select any port.

enter image description here

Extra info : I was trying to use Serial2 from another arduino to this, so i was changing some jumper wires while they were powered. So it is possible it is damaged. I also tried uploading some sketches to use a second serial with some modifications to the core of the OS. The changes were on the spirit of this post, but not necessairily the same.

3
  • the upload copies the bin to that drive. did you try the Upload? and double reset should activate the bootloader which should create a port.
    – Juraj
    Aug 24, 2022 at 9:51
  • I tried both double pressing the reset botton (a red light is not blinking, if it should) and uploading blink.ino. Nothing worked Aug 24, 2022 at 10:07
  • please post the message text, not a picture of message text
    – jsotola
    Aug 24, 2022 at 14:35

2 Answers 2

1

The RP2040 doesn't have a USB serial port unless you program it to have one.

Unlike "traditional" Arduinos the RP2040 uses the UF2 bootloader system. This involes the RP2040 pretending to be a USB flash drive, and then uploading code is as simple as copying the .UF2 file to that drive.

If you are seeing that drive then the chip is ready and waiting for you to upload code. You don't need to select a port in the IDE to upload the code since the port is not used for uploading (only for resetting the board to enter the bootloader mode, which you don't need since you are already in bootloader mode).

If the IDE is struggling to find the virtual flash drive then just find the .UF2 file that the IDE created and manually drag and drop it to that drive and it will program the code onto the drive for you.

3
  • I upload the Blink.ino.elf.uf2 from arduino help (docs.arduino.cc/tutorials/nano-rp2040-connect/…*iu9w36*_gaODM4NTQ0ODcuMTY1Nzc4MTAyNA.._ga_NEXN8H46L5*MTY2MTQxODM1NC41OS4xLjE2NjE0MTg0ODIuNjAuMC4w#board-not-detected), and still nothing happens. The arduino does not blink as it should, nor is there a COM port in the ide and device manager. Also, how can i manually create .UF2 files from the ide? (I got just a bin file from the option " Export compiled binary") Aug 25, 2022 at 9:10
  • You create .UF2 files when you hit the compile ("verify") button in the IDE. You just have to find them - it's not always obvious. Check the verbose output for hints. Do you have a link between REC and GND to always force the bootloader? If so, remove it.
    – Majenko
    Aug 25, 2022 at 10:07
  • It seems the IDE has a problem creating uf2 files. Actually, i have 2 arduino rp2040. One that works and one that doesn't. If I connect the problematic one, or i compile the programm without any rp connected, the IDE doesn't create a UF2 file. If i have the working one connected, it still doesn't create uf2 files until i press upload from the IDE. I tried using that uf2 file, but still the problem wasn't fixed. Aug 25, 2022 at 11:26
0

I had the same issue, even after following all the possible RESET/HARD RESET/BOOTLOADER procedures. I have found a solution for this board to regularly work under Windows, and this involves reintalling it as a DIFFERENT board.

What I became aware of, is that my Win OS (8.1) was not properly installing the Arduino Nano RP2024 driver, for reasons unknown. So, I was first trying to manually reinstall the driver after searching for the proper .inf driver file, which is located in "C:\Users<USERNAME>\AppData\Local\Arduino15\packages\arduino\hardware\mbed_nano\3.2.0\drivers". Unfortunately this come up with the same issue.

So I went for a "fake" manual install of the device, by selecting "Manually choose from a list of device drivers in your PC". I then selected "Ports (COM and LPT)", because this is how you would like your board to behave under your OS. THIS STEP IS ESSENTIAL. As far I could see, if you simply chose the Nano RP2024 .inf file located in the above folder, the boards will continue in not showing up in the COM ports list.

After this step, I went through a list of vendors, finding several Arduino-like entries. Among these, I selected "Arduino SA", which ws containing "Arduino Nano 33 BLE" as a device, which I found to be a working option. The board is now regulary showing up into the IDE, even after several connect/disconnect cycles, and also the serial monitor works.

NOTE: in case you select a different working mode of the board (e.g. HID peripheral such as mouse, keyboard or similar) you may have to reinstall it following the procedure above.

Hope this helps! Cheers Attila

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.