0

I just bought an Arduino Nano v3.0 (compatible? +- 5$) and I cannot connect it to my computer (Windows 8.1 64bit, Arduino IDE 1.6.8 installed).

The Arduino was bought as a clone but shows GRAVITECH.US on the front. It has a FTDI FT232RL chip (1412-G B8908572) on the back.

When connecting the Arduino the power leds burns the TX and RX led flash a few times (really shortly) and then die. Then the yellow L leds blinks once per second continiously.(power to the Arduino comes from the USB cable, not from external power)

In the system tray I get a message saying

"The last USB device you connected to this computer malfunctioned, 
and Windows does not recognize it."

In the device manager I get a node under Universal Serial Bus Controllers:

Unknown USB Device (Device Descriptor Request Failed).

When examining the properties of the device, the device-status is:

Windows has stopped this device because it has reported problems. (Code 43)
A request for the USB device descriptor failed.
  • I tried to reset the device
  • I tried different USB cables
  • I used another Windows 8.1 PC without Arduino IDE installed
  • I used an old XP computer

All give same error.

I read about the bricking of clones by the recent FTDI drivers... I downloaded the FT_Prog tool V3.0.60 to check the PID, but the tool simply does not find the Arduino...

I'm out of ideas... does anyone have some left?

Thanks in advance!

Michiel

2

I found the issue! There is a bug in the Arduino hardware: https://ketturi.kapsi.fi/2014/04/how-to-fix-moody-arduino-nano/

You need to bridge pins 25 and 26 of the FTDI chip (located at the back of the Arduino) to ground the pin 26 TEST signal. If I connect these pins then it works just fine!

  • It would be good to summarize the key point - bridging pins 25 and 26 of the FTDI to ground the pin 26 TEST signal, rather than relying on a link for the key element of your answer. – Chris Stratton May 9 '16 at 0:28
  • Thanks for the advice, I added the comment to my solution. – mvermand May 9 '16 at 6:08
0

I've had this issue before. You can try reuploading the bootloader. If that doesn't work, maybe try re-installing the drivers.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.