0

I am very new to all this, but have programmed in other languages using several IDEs. Last night when returning to a coding session, I noticed that the background of the sketch window had gone from white to gray. Then when I tried to continue editing the sketch, I found that I could not make any changes. At all. Clicking anywhere on the screen is futile; the cursor never appears. Text can be highlighted but not copied or pasted. In short, I can’t go on from here at all. What have I done?

  • 2
    You haven't done anything. It's Java. Notoriously bad at staying alive overnight. Kill it. – Majenko Aug 4 at 19:41
  • As one well-known IT guy would say, "Have you tried turning it on and off again"? :) – Duck Dodgers Aug 5 at 11:49
  • @duck dodgers: yes I have—multiple times. I’ve also tried using a bigger hammer and waving a dead chicken at it. I’ve not yet gotten to the point that I would kill a goat and examine its entrails, but I am getting close. – Chuck Aug 6 at 5:19
  • Interesting :). Then could you please possibly post a screenshot of the Arduino IDE here. I have never experienced something like this myself (barring minor glitches which one can get fixed by updating to a newer version). Could you please state then the version number of your IDE, what operating system you are using, etc. It would be helpful. – Duck Dodgers Aug 6 at 7:24
  • (see my penultimate comment first please) p.s. you can also try something other than the Arduino IDE, just for the time, that you try to debug the problem with the "Arduino IDE". – Duck Dodgers Aug 6 at 7:28

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.