0

I try to connect my NodeMCU Amica to my WiFi network, but it doesn't detect any networks around. I chose Board "NodeMCU 1.0 (ESP - 12E Module)", upload speed of 115200 and I have the correct port selected.

When I try the blink sketch, it works perfectly, but when I try to use the WiFiScan example, I only get the message "no networks found" and I don't.

I did pay attention that the upload speed in the sketch and monitor are always the same as the one I selected. Also, I tried out different upload speeds, without any succes either.

I already changed my network to 2.4 GHz, and also tried to downgrade the libraries to older versions, but nothing helped till now.

About any help, I would be really glad.

  • try to erase the flash with esptool to clear sdk settings if you changed firmwares and arduino package versions – Juraj Apr 14 '18 at 16:48
  • Ok, finally managed to get it running, but it still doesn't find any networks. By erasing the flash you just meant basically esptool.py --port /dev/tty.SLAB_USBtoUART erase_flash, am I right? – Robin Apr 14 '18 at 17:36
0

Firstly try to set it up as AP and check whether is it working ? If not, there is issue with power supply. Because WiFi Scan requires more current... than normal WiFi connection operation.

0
  1. Make sure you have entered correct ssid and password for that. It is very much case sensitive.
  2. Second reason for this can be insufficient amount of power supply supplied to it so make sure you are using good quality of power adapter for it. 3.https://tttapa.github.io/ESP8266/Chap07%20-%20Wi-Fi%20Connections.html Then try refering this link step by step... Hope this will help Thanks

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.