0

I am using a NodeMCU 1.0 v3 and I am trying the example sketch (wifiscan) but it just doesn't pick up any AP in the house. My phone and laptops etc are able to pick up the APs though.

Other sketches upload and work fine but the wifi aspect of it doesn't work. I even got an LCD sketch to work properly but it isn't able to find any access points or even join any access points. I have been trying to get it to work for hours now.

I first tried using the latest Arduino IDE (1.6.12), then I uninstalled and tried using 1.6.1 but no luck. My upload settings are NodeMCU 1.0 (ESP-12E module), 80Mhz, 115200, 4M (3M SPIFFS).

1

Your router might be using 5GHz Wifi which the ESP8266 doesn't support but your other devices likely do. Try setting your wifi network to 2.4GHz.

  • Thanks, I read on a forum somewhere that it could be the issue but when I checked my wifi it is indeed set at 2.4GHz. I also tested the esp8266 in an area with loads of APs so I ruled that out as an issue. – user20551 Sep 27 '16 at 11:53
0

My gut feeling is that your hardware is just flakey. I have one NodeMCU 1.0 that occasionally works, and occasionally does not.

On that one, it requires power cycling (unplugging and replugging) it a couple of times for it to start working.

The Arduino ESP8266 core is pretty solid, and wifi support should just work in it.

Just to make sure, you could post your simplest sketch which doesn't work (one that lists AP's, so that it can't be a ssid/password kind of issue), so people can check if there's a problem in the code..

Also, to be really sure, you could check your power system. NodeMCU has a 5v to 3.3v converter in it, and a usb plug, so that part should be ok. How many amps is the USB power supply rated at? If it's very low (<250ma) it could be an issue. You can also try adding a capacitor (something decent sized, >220uf at a random guess? I tend to go for ~1000uf) between gnd and 3.3v, and one between gnd and 5v pins. Watch polarity of-course, and double check, you don't want to short the power lines :) There's a very small chance stabilizing the power in that way might help..

  • Thanks for the answer cranphin. I suspect it may in fact be due to a faulty unit. I used the example sketch that lists AP's but that didn't return anything. I also tried powering it separately using a 3.3v 2A supply. I think i'll just use it as I would a Arduino Pro mini because all other sketches except anything to do with wifi works. I'll add some caps as you suggested and see if it helps. Thanks again. – user20551 Sep 27 '16 at 11:52
0

My DHCP table was full. I rebooted router and added more values for dhcp range (192.168.1.100-192.168.1.150) and the device now connects.... took me a day to figure this out.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy