0

I have uploaded the BasicOTA sketch in Esp8266-12e. I am written one program, when i try to upload it first time in Esp using the OTA port it gets uploaded successfully, but when i try to upload any sketch after that it does not work. The console responds with No Answer.

After searching on internet many people have asked to check the sketch size. To check if size matters or not i tried with blinking sketch, and same issue happens there too.

The sketch only gets uploaded in first time.

Can anyone guide me resolving this issue.

1
  • 1
    the uploaded sketch must use the ArduinoOTA library to handle the next upload
    – Juraj
    Apr 8 '20 at 18:01
2

Things to check:

  1. Partition arrangement selected. You have to make sure to keep the same partition arrangement between uploads.
  2. Partition arrangement selected. You have to make sure that the partition arrangement you have chose supports OTA uploads.
  3. You have to reset the ESP8266 manually after your USB upload. You can only do an OTA update to a sketch that has booted in "run" mode, not "boot" mode.
  4. You have the right IP address / hostname selected? (I don't know how that is handled in the Arduino IDE...)
  5. You must upload an OTA-enabled sketch for OTA to continue working.
6
  • 1
    I honestly believe that this issue is related to the fact that the sketch uploaded through OTA doesn't itself include the OTA code to allow for further OTA upload. For example, the Blink sketch would fail to allow OTA comms as soon as it was loaded. Might want to add another point to your list. I'd post myself, but you've already started a decent troubleshooting list here.
    – stevieb
    Apr 8 '20 at 18:24
  • 1. Partition Arrangement Selected-> Do u mean to say flash size ?? its 4MB FS:NONE , OTA:1019kb. 2. How to ensure that. 3. Yes i do reset it manually after uploads. 4. Ip address is confirmed to be correct. i print it on display.
    – java bee
    Apr 8 '20 at 18:25
  • 1
    @stevieb Does that mean, i have to include the OTA code in every sketch i want to upload to esp.
    – java bee
    Apr 8 '20 at 18:26
  • 1
    @stevieb Good point. Added as point 5.
    – Majenko
    Apr 8 '20 at 18:27
  • 1
    @javabee Yes, if you don't have OTA code in your sketch then OTA can never work. It's the sketch that provides OTA, not some magic pixie dust.
    – Majenko
    Apr 8 '20 at 18:27

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.