0

Could anybody please help me with my problem? My Arduino doesn't work correctly. I was between a project, and suddenly it started acting weird. First, it started taking about 4 minutes to compile and a minute to upload, I do not know why!

Second, now it doesn't accept any code at all. I will paste the error message below.

Also, could anything be damaged as I inserted the USB cable of the Arduino to my power bank, rated 5V 2A, for about 30 seconds as power source and then again inserted it to the computer itself.

Please help me. I have already tried searching on various forums, reinstalling the software and driver on my PC, pressing the reset button... No help so far.

ERROR MESSAGE: Arduino: 1.6.7 (Windows 10), Board: "Arduino/Genuino Uno"

avrdude: Version 6.0.1, compiled on Apr 15 2015 at 19:59:58 Copyright (c) 2000-2005 Brian Dean, http://www.bdmicro.com/ Copyright (c) 2007-2009 Joerg Wunsch

System wide configuration file is "C:\Program Files (x86)\Arduino\hardware\tools\avr/etc/avrdude.conf"

Using Port                    : COM6
Using Programmer              : arduino
Overriding Baud Rate          : 115200
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 1 of 10: not in sync: resp=0x49
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 2 of 10: not in sync: resp=0x49
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 3 of 10: not in sync: resp=0x49
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 4 of 10: not in sync: resp=0x49
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 5 of 10: not in sync: resp=0x49
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 6 of 10: not in sync: resp=0x49
Error opening serial port 'COM6'. (Port busy)
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 7 of 10: not in sync: resp=0x49
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 8 of 10: not in sync: resp=0x49
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 9 of 10: not in sync: resp=0x49
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 10 of 10: not in sync: resp=0x49

avrdude done.  Thank you.

Problem uploading to board.  See http://www.arduino.cc/en/Guide/Troubleshooting#upload for suggestions.

marked as duplicate by dlu, The Guy with The Hat, Nick Gammon, James Waldby - jwpat7, Avamander Jan 21 '16 at 20:44

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

1

Connecting to the 5v/2A power supply would cause no trouble at all. Taking 4 minutes to compile is strange but unlikely to be related to the Arduino board. "programmer is not responding" errors are communication errors.

  • Did the program compile without errors?
  • Are any LEDs lit or blinking on your board?
  • Is the correct board selected in the Tools | Boards menu?
  • Is the correct port selected in the Tools | Ports menu?
  • Is the correct programmer selected in the Tools | Programmer menu?
  • Try another USB cable.
  • Try pressing/releasing the board's reset button right after you click the upload button.
  • Don't forget the programmer option! – Alexander M Dec 27 '15 at 0:25
  • yes it compiled without errors yes LED on the board blink like normal yes correct board is selected yes correct port is selected programmer im nt sure.... wat exctly shud it be? another usb cable, ok il try that soon as i get my hands on another cable, i tried the reset button thingy...dint work :( – Swapnil P. Kumar Jan 3 '16 at 16:11
0

I am getting the same exact errors. Tried different boards, cables, upgrade to 1.6.7, etc. Maybe will go back to pre1.6 and try. Will also try via tinyisp when I get a chance. FYI - having no issues with studio 6/tinyusb/avrdude combination, just on arduino. Wonder if it is a USB driver or arduino version of avrdude problem?

  • Confirmed - no problems uploading via usbtinyisp. Must evolve around Arduino USB? – John Clements Jan 4 '16 at 18:05
  • Another confirmation - not only does usbtinyisp work good but I can also read the serial port in Putty. Definitely something going on in Arduioland! – John Clements Jan 4 '16 at 18:08

Not the answer you're looking for? Browse other questions tagged or ask your own question.