I am configuring the arduino IDE to be able to compile and upload sketches for the arduino wavgat uno R3. I have installed the Arduino IDE, as well as the required drivers for the board. I also have downloaded the zip containing the "hardware" and "librairies" folder that i copied into the "Arduino" folder.

In the IDE, I can select the wavgat uno R3 as a board and the board is detected by the IDE.

However, when I try to compile any sketch, I get the following error message :

avr-gcc: error: C:\Users\henry\AppData\Local\Temp\arduino\sketches\F2EF7F804783EB75A0A6457CF6D8C244/core\core.a: No such file or directory

exit status 1

Compilation error: exit status 1

I seems to be a problem related to the compilation. Is there something related to the compilation for the wavgat uno R3 that I forgot ?

Thank you in advance

  • did you try to restart the IDE?
    – Juraj
    Jun 27 at 18:11
  • Yes, I even tried to restart the computer altogether.
    – Sorenai de
    Jun 28 at 8:28

1 Answer 1


The problem was solved by using a specific version of the arduino IDE, the 1.8.15. You have to install the drivers and copy the correct driver files in the Arduino folder. The program then compile correctly and can be uploaded to the wavgat.

Also, when working on the wavgat nano, you have to select "WAVGAT UNO R3" as the board type, and not "WAVGAT NANO 3.0" as you might first think.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.