1

Whenever I try to compile a script, the Arduino IDE throws the error avr-g++: error: CreateProcess: No such file or directory. I've already tried reinstalling the IDE, changing the board version in the board manager to 1.6.21, and deleting the Arduino15 folder under AppData/Local/Arduino15. This problem appeared suddenly - one compilation worked, and two minutes later, nothing would compile - and occurs across all scripts that I've tried.

I'm working from Windows 10 and compiling for an Arduino Uno.

  • 1
    Antivirus playing merry hell with your installation? – Majenko Jul 9 at 11:56
  • Just checked my activity log and that's exactly what's going on. Thank you! – Snail Cadet Jul 9 at 12:02
1

Turns out that McAfee's Host Intrusion Prevention had decided to start blocking avr-g++.exe. Not sure why it did so all of a sudden, but it's an easy fix once you know where to look. Anyone finding this in the future should be sure to check their antivirus logs to see if the compiler's executable is being blocked.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.