1

I built a new pc which I use as a flight simulator. On my old PC I had ArduinoIDE for programming a pro micro as well as a teensy 4.1 using the teensyduino library. I installed all the necessary libraries and can make revisions to the code for the Teensy and successfully upload them. However when I try to upload anything to the arduino I get the above mentioned error. The old pc could program the arduino without a problem.

The arduino is showing up in device manager and it disappears when the usb cable is unplugged. The correct port is chosen in the tools menu and I can get the board info. I just can upload it to the board. Still using windows 10 pro, the same OS as on the previous pc.

Running the arduino IDE (v2.1.0) as admin does not help.

4
  • Are you sure the port number is correct and not open by another program?
    – PMF
    Apr 20, 2023 at 9:26
  • using usbtreeview.exe shows me the same info as device manager. The arduino is seen on com 6. I could post the output of usbtreeview but it exceeds what I can do in a comment and it is ugly. I just freshly booted this pc with only the arduino a keyboard and mouse as well as a hub connected. Apr 20, 2023 at 12:33
  • 1
    Can you open the console window? Or does that print the same error?
    – PMF
    Apr 20, 2023 at 13:32
  • Please take the tour and read "How to Ask" to learn how this site works. This is not a forum. Therefore, you do not add new information or clarification in a comment. Instead, edit your question, and you have all features available, space and formatting. Apr 20, 2023 at 14:58

1 Answer 1

0

Installing Arduino 1.8.19 solved the problem. I guess v2.1.0 has some code that trips over itself.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.