1

My Arduino Nano v3.0 (made by Gravitech US) is behaving in an unexpected manner. Whenever I try to upload a simple Blink program on the board it always give error which is shown below.

avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 1 of 10: not in sync: resp=0x01
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 2 of 10: not in sync: resp=0x01
...

I have another Nano (a Clone) and an Arduino UNO, both of which work perfectly using the same USB cable and PC.

History: When I used this Nano (original) for the first time, it was having some issue related to the FTDI chip. The FTDI USB was locking up on power up. I referred an answer from Arduino Nano 3.0: FTDI USB locks up on power up. I shorted the pin no. 26 (TEST) and 25 (AGND) on the FTDI chip, and then I was able to use it. I uploaded the Blink program and tested it, which was working fine.

Now, at present (three years later), when I try to upload even a simple Blink example sketch on it, it never succeeds, and gives me the above mentioned error.

I also tried holding the reset button and releasing it when it shows

Uploading...

Another Issue: Sometimes when I just check the continuity on my Arduino Nano just to confirm whether the hardware is okay or not, it gives me unexpected results. On checking, the Pins RST and GND get shorted sometimes. And sometimes even VCC, RST and GND get shorted. I also checked the small reset switch on board, and it is working fine.

I contacted Gravitech, but they aren't responding.

What can be the issue with my arduino Nano? I haven't used it yet in any of my project. Just the Blink program that I uploaded 3 years ago on it, was the last time I saw it working.

Any help would be greatly appreciated.

  • Have you verified that the RST pin isn't shorting to ground when uploading? (After the reset button is released, of course). – legowave440 Mar 8 '16 at 18:46
0

Select Tools>Processor>ATmega328p(old bootloader)

I was having the same problem. The default uploaded sketch was causing the problem. The code was reading one of the analog pins and throwing the value via serial port and causing the problem. Changing to old bootloader fixed it for me

  • good morning. this is a question from 2016. new bootloader for Nano was introduced this year with the Old bootloader option in IDE – Juraj Dec 12 '18 at 17:51
  • Ow i didnt know this. I faced this problem recently and found this fix working for me so i shared. Cheers – mursalat Dec 14 '18 at 4:21

protected by Juraj Dec 12 '18 at 17:51

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.