0

I'm a newbee to Arduino programming and hoping someone can help me with this. These are the error messages.

avrdude: stk500_rcv() : programmer is not responding

avrdude: stk500_getsync() attempt 10 of 10:not in sync:

Problem uploading to board.

I'm using a Arduino UNO clone on com port 3,the blink sketch is functioning. I get the mentioned error message on all sketches I have ran. Not sure what to do.

  • Are you running Arduino IDE, and get the message when you click upload? What board model and speed is the IDE showing at its bottom right? What programmer, in preferences? Have you tried things suggested in 'Related' questions in sidebar? Have you uploaded to any other boards? Please answer the above by editing your question – James Waldby - jwpat7 Nov 27 '15 at 3:26
  • And what do you mean by "the blink sketch is functioning" and "error message on all sketches"? Is the blink sketch working or not? – frarugi87 Nov 27 '15 at 10:07
  • Yes the blink sketch works fine. In fact all the LED sketches work. I get the – Tom Evans Nov 27 '15 at 11:57
  • Yes the blink sketch works fine, in fact all the LED sketches upload successfully. When I upload any other sketches such as LCD, stepper and servo I get the mentioned errors. Thanks for your help – Tom Evans Nov 27 '15 at 12:04
2

I had a same problem with UNO R3 (CH340G) MEGA328P for Arduino UNO R3

On Ubuntu 14.04 I checked the whether the USB chip not recognized, but it looks ok:

~$ dmesg | tail -n 6

[ 3350.417900] usb 2-2: new full-speed USB device number 5 using xhci_hcd
[ 3350.546759] usb 2-2: New USB device found, idVendor=1a86, idProduct=7523
[ 3350.546763] usb 2-2: New USB device strings: Mfr=0, Product=2, SerialNumber=0
[ 3350.546764] usb 2-2: Product: USB2.0-Serial
[ 3350.547255] ch341 2-2:1.0: ch341-uart converter detected
[ 3350.547996] usb 2-2: ch341-uart converter now attached to ttyUSB0

But the upload went wrong like this:

~$ avrdude -C/usr/share/arduino/hardware/tools/avrdude.conf -v -v -v -v -patmega328p -cstk500v1 -P/dev/ttyUSB0 -Uflash:w:/home/oliver/Arduino_Build/Blink/Blink.hex:i

avrdude: Version 6.0.1, compiled on Oct 21 2013 at 15:55:32
         Copyright (c) 2000-2005 Brian Dean, http://www.bdmicro.com/
         Copyright (c) 2007-2009 Joerg Wunsch

         System wide configuration file is "/usr/share/arduino/hardware/tools/avrdude.conf"
         User configuration file is "/home/oliver/.avrduderc"
         User configuration file does not exist or is not a regular file, skipping

         Using Port                    : /dev/ttyUSB0
         Using Programmer              : stk500v1
avrdude: Send: 0 [30]   [20] 
avrdude: Send: 0 [30]   [20] 
avrdude: Send: 0 [30]   [20] 
avrdude: ser_recv(): programmer is not responding
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 1 of 10: not in sync: resp=0x00
avrdude: Send: 0 [30]   [20] 
....

After reading bunch of articles 1, 2, 3, 4, 5, 6 it turned out my bad Chinese Arduino clones does not have bootloader installed on the Atmel microcontroller ship. To solve this problem you need a working Arduino and the clone Arduino we want to fix.

Walk trough who to burn the bootloader: http://www.instructables.com/id/How-to-fix-bad-Chinese-Arduino-clones/

Shortly: Burn the bootloader

Arduino as ISP

  1. You need a working Arduino
  2. Connect the working Arduino with a usb to the computer
  3. Upload Examples->ArduinoISP on working Arduino
  4. Connect the wires from the working Arduino to the clone as follows:
    • Pin 10 goes to reset pin
    • Pin 11 -> 11, 12 -> 12, 13 -> 13
    • 5v to 5v and ground to ground
  5. Go to Tools->Board and select the chinese board that is not working. in my case it's an Arduino Uno.
  6. Go to Tools->Programmer and select Arduino as ISP.
  7. Go to Tools again and select "Burn Bootloader".
  8. Your clone should work just fine now, but don't forget to restore Programmer (set back to ArduinoISP or AVRISP).

My clone board does not had integrated LED on 13 pin :) you need to connect it for Blinking test.

1

try this site: https://github.com/Makeblock-official/Makeblock-USB-Driver/ , it works for me. This is a driver for arduino, and command for bash

1

You mentioned arduino uno clone, do you know what USB chip it's using and what chip you are uploading the sketches to?

The clone I have is very fussy and hangs up continuously. I have had luck once or twice with uploading the sketches. Depending on the chips on the board downloading the proper driver will help and selecting the proper chip under the board setting i.e. Atmega328 or atmega8 depending on the chip. Hope this helps as it worked for me.

0

I assume that you're trying to upload the code with the Rx and Tx pins connected..
Try removing the Rx and Tx and then click the upload button in the IDE..

This happens because your computer communicates with the Arduino via Serial communication. The Rx and Tx pins also do communicate via Serial communication. An Arduino does not have the capability to handle two such communications simultaneously. So, it goes out of sync.. And that's how you get this error...

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.