0

I'm newbie in Arduino Dev

I got Arduino Uno R3, at first it just worked fine. I tried to upload my whole project sketch which almost up to the max size of arduino memory.

Then suddenly the upload failed, and i can upload any other sketch even an empty or simple sketch.

I already remove all cables connected, still failed to upload.

I really dont know how to fix this.

  • The answer below covers everything I would think to try, and most of us have been in this boat at one time or another. It's frustrating. If you got this going, please come back and tell us what the issue was, it might help someone else down the track. If you're still having issues, update with everything you've tried and include some more details (OS, what you've got connected to the board, alternate port results etc). And welcome to SE Arduino! – Madivad Nov 24 '15 at 15:21
1

First stop for me is always the connections (which you've done), the sketch itself (which doesn't sound likely) and then the COM port / baud rate. If your sketch involves anything with the serial connection, ISR's or power supplies, that could be an issue with the Arduino not listening. It sounds like you've covered this as well by trying simple sketches. Next, check the COM port on the host computer (sometimes it changes in Windows) and inside the IDE, the baud rate, and open the IDE serial port and wander through baud rate settings until you get something legible as a response in the serial window. Also, double check inside the IDE that you still have the correct board selected. Occasionally / rarely, I've had to reboot Windows to cure the problem.

The good news is, this pain is significant enough that you don't usually make the mistake again, and will probably never forget how you solved it....

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.