2

In our electronics tinker club, we had installed Arduino IDE 1.8 including drivers + the Holtek UART bridge (vendor ID 04D9, product ID B534) for the Elegoo Smart Car Kit 3.0 Plus (product link). The board is an Arduino Uno clone.

We now installed Arduino IDE 2.0.3 in parallel and tried that one, because its features looked promising.

However, in Arduino IDE 2.0.3, we had problems uploading the compiled sketch to the Smart Car Board. When I checked, it reported a different vendor ID and product ID (sorry, I didn't record which one).

I reinstalled the Holtek UART bridge driver (direct download executable) and tried again. The vendor ID and product ID were correct this time, but uploading was still not going well in Arduino IDE 2.0.3.

Switching back to Arduino IDE 1.8 doesn't help. While the code still compiles (I expected it to), the upload problems now affect Arduino 1.8 as well, which was totally fine before we installed Arduino IDE 2.0.3.

How could I fix this issue?

I'll try to uninstall and reinstall everything, but I'm not sure it will be possible to uninstall all drivers.

5
  • You might want to add the command line and output of the call of avrdude. Mar 1, 2023 at 7:20
  • @thebusybee: thanks. I don't yet know what that is, but I'll inform me about that and post it when I know it. Mar 1, 2023 at 7:59
  • BTW: I upgraded 4 PCs to Arudino 2.0.4. It seems to work better on 2 PCs (upload works), but the other 2 still have the same problem. Mar 1, 2023 at 8:00
  • 1
    In the IDE you can see in the output view the commands executed and their responses. You might need to set the respective option in the preferences. Copy this output as text into your question, please. -- Avrdude is the program that actually uploads the compiled sketch. Mar 1, 2023 at 8:52
  • @thebusybee: thank you for this hint. It helped me a lot when diagnosing and comparing the different results. Since I had 9 robots and 8 noteboks, I had so much output and text for debugging purposes, I was reluctant to put it into the question. I have now posted an answer on this question. Mar 9, 2023 at 19:17

1 Answer 1

2

I spent more time (almost 20 working hours) to isolate this problem by

  • testing the behavior with all of our 9 robot hardware in the club
  • testing the behavior with all of our 8 notebooks in the club
  • testing with the 6 different implementations we had, bricking and not bricking our robot hardware
  • testing with an additional notebook that didn't seem affected
  • combinations thereof

Finally I had a reproducible procedure with which I could "brick" a robot hardware and another procedure which would "unbrick" it.

That way I was able to a) minimize the code that was needed to "brick" the robot and b) compare that to the other codes that didn't have the issue. Finally I could ask this new question and get valuable feedback.

It turned out that this was not related to the new Arduino 2.0.3 or 2.0.4 IDE. It was just a timely coincidence that we wrote a new sketch we never wrote before in this way for this hardware.

That code used Serial.begin() with a "high" baud rate and obviously less delays than we ever used on this hardware before. And it turned out our hardware can't handle speeds higher than 19200 baud (!) without delay() statements. That's so slow!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.