9

I bought an Arduino-compatible Freaduino board atmega8 (I selected the board type as Arduino ng or older atmega8). I installed the Arduino IDE on Mac OS X and the FTDI drivers. But my serial port looks like this when I connect the board:

screenshot 1

And when I try to upload the program, this is the error I get:

screenshot 2

Can someone tell me what is the mistake? I am clueless.

UPDATE: the problem was I had not installed the driver properly (I guess). I uninstalled and reinstalled them and it worked perfectly. Also made a YouTube tutorial regarding the same. http://youtu.be/BwatajQO_88

  • Have you set the Board correctly to the one you have? Also, almost definitely it is not the Bluetooth tty that you have connected to. Very likely it is the USB tty. – sathishvj Jul 16 '14 at 14:49
  • yes the led (PWR) glows on the board as soon as i connect it. – Rajath Jul 16 '14 at 14:51
  • i tried tty.SLAB_USBtoUART to. it dint work same error – Rajath Jul 16 '14 at 15:05
  • Disconnect the board, close the IDE, and re-open it. Did any of the devices disappear? Also (with it plugged in) do apple-menu about - more info - system report and look at what is listed under USB. Finally consider trying it on a different computer/OS to rule out problems with the board. Oh, and try a different cable/USB port. Try connecting it directly to the MAC and try connecting it through a keyboard or other hub. – Chris Stratton Jul 16 '14 at 15:57
  • Why not copy the plain text instead of uploading the lower 372kB image? Search engines won't be able to index the text and mobile users are hit with a large download where 1kB of text would suffice. – jippie Jul 16 '14 at 16:19
8

From the OSX System Report we learn that your board is based on an SiLabs CP2102 converter (or workalike), but according to your question you installed the drivers for an entirely different product from FTDI

(Arduino.cc has used FTDI in the past and CDC/ACM today, I don't believe they have ever used SiLabs so their instructions probably don't cover that, but other vendors obviously have)

Install the CP2102 drivers and it should work if you use the /dev/tty.XX device which then appears when you plug in the board.

SiLabs appears to provide the drivers at

http://www.silabs.com/products/mcu/pages/usbtouartbridgevcpdrivers.aspx

Just for sake of completeness, there are at least 5 distinct protocols/chips in use for serial-like USB communication with embedded devices:

  • FTDI
  • CDC/ACM Virtual Com Port
  • SiLabs CP210x
  • Prolific PL-2303
  • ch340

(Additional possibilities could include actual RS232 serial or serial-over-bluetooth)

  • first i installed FTDI. as it dint work and then i found this link as one of the answers were to install silabs drivers i installed them too. but not working. i tried this before only. really appreciate ur effort to help me out. – Rajath Jul 16 '14 at 17:44
  • You do seem to have device files for that driver in your list. If it didn't work when you selected those, you might have the wrong baud rate (from the chosen board configuration). Another possibility (especially with alternate sources) is that you have a bad board - the CP2102 chip might be okay, but that doesn't mean that the AVR is, or that is has a bootloader programmed. I'd probably try different baud rates, try burning a bootloader via ISP, etc. But ultimately, why are you bothering with an ATmega8 board? – Chris Stratton Jul 16 '14 at 17:49
  • how do u change the baud rate? i have taken up a project which was not completed by my senior. so he has used that board. – Rajath Jul 16 '14 at 18:28
  • I think you may have to create a new "board" entry in the configuration and edit the baud rate in its file, then restart the IDE. You might as well create several for different board rates. – Chris Stratton Jul 16 '14 at 18:41
  • u mean something like this ? – Rajath Jul 16 '14 at 18:52
4

just to add to the list - some cheaper boards use CH340 chipset

here is a blogpost on how to install the drivers on OSX http://javacolors.blogspot.ie/2014/08/dccduino-usb-drivers-ch340-ch341-chipset.html

From that post:
You can find drivers for this chip on the web site of the chinese manufacturer, here :
http://www.wch.cn/downloads.php?name=pro&proid=5

0

http://arduino.cc/en/guide/macOSX

That link should almost definitely get it working for you. Ensure (as in Step 7) that the board you have is the same one that is selected in Tools->Board.

And in step 8, since you have connected via a USB cable, it should be one of the USB named options.

  • its an atmega8. i have selected arduino ng or atmega 8 board. the USB is not appearing in the serial port though the arduino is connected the PWR does light up. – Rajath Jul 16 '14 at 14:59
0

If you still have problems, like me after following the above, this might help: From this thread: http://forum.arduino.cc/index.php?topic=292284.msg2229300#msg2229300

the problem is in the spaces of the device name. To fix that you have to manually edit two (2) txt files of the arduino installation.

Go where you have installed it. In my case the path is:

/Users/MY_USERNAME/Downloads/Arduino.app/Contents/Java/hardware/arduino/avr

Inside this directory you can see files platform.txt & programmers.txt.

Inside these files replace -P{serial.port} with "-P{serial.port}". So you simply have to add the quotes.

Then restart.

protected by Community Feb 16 '16 at 21:13

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.