1

I bought an Arduino Mini and also an Arduino USB 2 Serial Converter. While trying to program the Arduino Mini, I get this error:

avrdude: stk500_getsync() attempt 8 of 10: not in sync: resp=0x00

After doing some research I tried many things like changing the settings, serial port, made sure I'm using the right Arduino etcetera.

Some points to consider:

  • I tried burning the bootloader using my Arduino Uno.
  • Uploading sketches to the Arduino Mini using my Arduino Uno works (so problem is not directly with the Mini).
  • I am pressing the Reset button before uploading. I also tried hooking a capacitor and the Reset wire directly. No change.

The wiring (I also tried connecting TX of Mini to RX of serial converter, and vice versa):

enter image description here

1

The Arduino USB 2 Serial converter was defect (even though brand new). I bought a cheaper (7 Euro) FTDI to USB and I can now upload.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.