2

I've been using my Arduino UNO without a hith for a few days now, but suddenly I can't program it anymore.

When I try to programm my Arduino on Mac, I get the following Error:

avrdude: stk500_recv(): programmer is not responding

The USB option under serial port has disappeard (It was there before). Has anyone an idea on how to fix this?

The last thing I did is use the serial port for some communication. A reboot hasn't improved anything.

I tried programming Linux, but it resulted in the exact same result.

  • Related: arduino.stackexchange.com/questions/804/… Does that solve your issue? What board are you using? – Anonymous Penguin Jun 18 '14 at 20:12
  • No is doesn't solve the problem. Besides that: I use an original Arduino Uno. – Stein Jun 18 '14 at 20:17
  • On Linux go to computer>var>lock and delete the serial port lock files – Handoko Jun 19 '14 at 22:44
3

It seemed to be a hardware problem on the board. Thanks for the effort.

1

If I try to upload with no device connected, I get a dialog with the message "port is blocked" and a message in Eclipse's console window that the port is not found.

So I'm guessing you've got a sync problem. UNO should reset automatically when avrdude connects. Try manually resetting it just before you click to start the download. If that works, then the automatic reset has failed.

  • If I try to upload with no device connected, I still get: "avrdude: stk500_recv(): programmer is not responding" – Stein Jun 18 '14 at 21:06

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.