0

Having a problem running my original code that I tested last week, which worked on multiple days last week.

I tried to do a DFU reset and update the BootLoader, but it didn't work. I checked the baudrate and board selections in the Tools tab, but those were fine.

I didn't change anything in the code, I checked the wires on the hardware setup (nothing looks loose).

Thought it could be an error with the USB cable, changed the USB cable to a different one, still same error.

Also - using a Mac. But the same issue arose on the Windows PC. Did not try to reset using the Windows computer, but reset issue has more to do with the other hardware?

Checked the serial port - and it's selected to right one. enter image description here

enter image description here

Error Posting - no data from the serial port

  • Maybe you should choose the right serial port. – Majenko Jul 24 at 15:55
  • True, forgot to mention that. I did check that though, I only have one serial port (have a driver to be able to get serial data on the Mac - and that has worked). It's selected to the only valid serial port. – ThermoRestart Jul 24 at 16:04
  • Clarification - to do a DFU reset - you have to make sure the DFU and ground pins are connected with a jumper wire. You click the reset button - and try to update the bootloader? – ThermoRestart Jul 24 at 16:08
  • 1
    Well, the port you have selected is (the hint is in the name) a bluetooth port, not a USB port. – Majenko Jul 24 at 16:17
  • 1
    It seems to be working. Thanks. – ThermoRestart Jul 24 at 16:19
0

Step Zero - check that the port selected works.

Step Next - if you still get the error, try the DFU reset options and follow the steps outlined in the link below.

https://learn.adafruit.com/bluefruit-nrf52-feather-learning-guide/using-the-bootloader

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.