2

I started a new motor related project recently with a new Arduino Uno, beginning with several tutorial circuits included in the Vilros Arduino guide. The circuit in question is #10, a simple DC motor circuit with a transistor switch (http://imgur.com/a/vaqUA). The Arduino is being powered for the moment via USB.

The circuit, completed according to the diagram/common sense, does not work. The voltage across the transistor base is clearly not sufficient to activate the switch with the motor in the circuit. 5V (more like 4.6V) from Pin 13 is running across a 330 ohm resistor to the transistor base, but there is no current between the collector and the base. Bypassing the collector/base gap with a piece of metal will complete the circuit and activate the motor.

For some reason, the transistor will switch properly when the motor is replaced by a simple LED. AND, switching the cable from Pin 13 to the +5V out is enough to activate the transistor switch. I was under the impression that the transistor should only require .7V above the common grounded element.

But, even more bizarrely, with a cable running from +5V to the transistor base (through a resistor), a voltmeter across the DC motor is reading a potential difference of anywhere from 9V to 1702V (see http://imgur.com/a/08I3W, yes, with 4 digits). The multimeter is otherwise working normally, so I don't see a good explanation. Is the Arduino pin just incapable of providing sufficient current/voltage to activate the transistor, or am I missing something obvious. And does anyone have some idea why the voltmeter is reading so high and fluctuating so wildly? It is curious that the Arduino disconnects from the PC whenever the circuit is completed with the motor in it, so the Arduino likely is overdrawing from the USB.

The transistor included was not the one listed, but a common MPS2222A.

Thanks

1

There is nothing wrong with the circuit (although drawn in a bizarre method). Your understanding of how a transistor works is mistaken - forget voltage - transistors are controlled by current.

Most likely you have connected the transistor incorrectly.

The voltage reading is due to back EMF. If you used an analog meter it would give the reading you expect.

In all likelihood you have damaged the transistor.

  • Thank you. I have some background in physics, but none at all in circuit/semiconductor theory, although I'm learning. The voltage reading makes sense. A damaged transistor does seem likely, although I've replaced the transistor twice with an identical one to no avail. Curiously, the transistor works properly if I wire the transistor base to the 5V out instead of an Arduino pin. Is it possible that the pins can't provide sufficient current across the (possibly damaged) transistor while the 5V out can? Thanks again. – JAustin Jul 21 '16 at 5:20
  • 1
    @JacobAustin The Arduino can supply 20mA, but with a 330Ω should put 15mA into the base (you can measure this by putting the meter in series on a mA range). This should be more than sufficient to saturate the transistor and be able to switch its 600mA current. If it isn't turning it on you have a wiring error (most likely reversed C E) or damage. The transistor does seem to be reversed in the image. – Milliways Jul 21 '16 at 6:38
  • Okay. Thanks again. Curiously, I was able to attach a 9V battery to the Arduino and everything worked fine. It's possible that I damaged the USB by drawing too much current, and that was limiting the current supplied by the Arduino across the transistor. – JAustin Jul 24 '16 at 14:46
1

According to second image transistor seems to be connected in oposite direction (switched Collector with Emitter). It means common collector configuration is used instead common emitter and it's usually not enough to drive motor. And C-E can handle only about 10V Max (more or less, depends on transistor) even if it could handle much more in oposite direction.

See link for more details:

  • Common Base Configuration – has Voltage Gain but no Current Gain.
  • Common Emitter Configuration – has both Current and Voltage Gain.
  • Common Collector Configuration – has Current Gain but no Voltage Gain.

I've just tested this circuit an it must be powered by power jack. USB is not strong enough.

  • The transistor that came with the diagram was itself reversed. Emitter-base-collector, instead of collector-base-emitter. I have also tried reversing the transistor to no avail. – JAustin Jul 21 '16 at 5:01
  • @JacobAustin that's true for 2N2222 and PN2222 but for P2N2222 is schematic correct. SparkFun Inventors Kit contains P2N2222. – KIIV Jul 22 '16 at 20:01
  • The kit contained the wrong transistor. It was an MPS2222A transistor. However, attaching a 9V battery seems to have solved my problem. Probably an issue with current draw from the board. – JAustin Jul 22 '16 at 23:03

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.