Few weeks ago my Arduino Uno (IDE version 1.8.2) detected the USB port and I was able to do some small IOT projects. I updated my OS to Sierra 10.12.5 and now suddenly the usb serial option has disappeared.

enter image description here

I followed this link : https://learn.sparkfun.com/tutorials/how-to-install-ftdi-drivers/mac where it tells us to download and install the FTDI drivers separately. I tried that but it did not help.

Then I came across this post: https://forum.arduino.cc/index.php?topic=427825.0 where the user is having this same problem with MacOS Sierra. He suggested we remove the FTDI drivers and rely on Apple's drivers. So I removed the FTDI drivers from my Mac so it will use Apple's drivers.

Now even after doing all this when I connect my Arduino Uno to my Mac via the USB it does not get detected.

I removed the kext and pkg files for the FTDI drivers and deleted them completely, still when I open the System Report I still see the FTDI USB Serial Driver entry.

enter image description here

When I go to System Report > Hardware > USB I see this:

enter image description here

What is happening? Did the FTDI drivers got removed? If they did then why wont the serial usb port get detected on Arduino? If they are not removed completely then what did I miss?

  • If you have a genuine Arduino you don't want the FTDI drivers. There hasn't been an FTDI on an Arduino for many years. If you have a cheap Chinese clone then you probably want the CG340G drivers (and good luck with those). Genuine Arduino boards use a CDC/ACM interface, and all modern operating systems have those drivers built in. – Majenko May 28 '17 at 10:38
  • I am not sure if my Arduino is genuine or cheap chinese knockoff. I got it off from Amazon as a part of IOT starter kit. It worked properly in the beginning and as I mentioned I did some projects on it. – codeinprogress May 28 '17 at 11:24
  • Unless you went through the rigmarole of installing the CG340G drivers (and you'd remember doing that, trust me) then it's probably like a genuine Arduino (with an ATMega16U2 chip as the USB interface) - however, is it actually genuine? Only a picture of the board could tell us that (there's telltale signs you can see if you know what you're looking for). If it's not genuine then it could be that the USB interface chip is dead (it may be a cloned chip or a factory reject). – Majenko May 28 '17 at 11:26
  • Found this on youtube: youtube.com/watch?v=wyocdvAKo64&t=0s what do you think? – codeinprogress May 28 '17 at 11:28
  • That's for cheap chinese clones only - CH340G. Post a picture of your board please. – Majenko May 28 '17 at 11:33

I installed the CH340 Driver and the board now shows the USB serial as port option: https://github.com/adrianmihalko/ch340g-ch34g-ch34x-mac-os-x-driver

  • 1
    This cannot be an answer to the question asked, as the Uno does not have a CH340. Either the question or the answer is incorrect. – Chris Stratton Nov 26 '17 at 18:14
  • @ChrisStratton I am fairly new to IOT and electronics in general. I did what I could to find a solution to my problem and it worked. If you are so enlightened in this matter then please feel free to give a "correct" solution to my problem or "correct" the questions. – codeinprogress Nov 27 '17 at 4:42
  • I had the same problem w/ an Arduino Uno after upgrading to Sierra--no issue with USB port detection before upgrade and issue afterwards. I downloaded and installed the driver from the said github repo and then after reboot, it worked! Thanks for offering this solution. – danlee Dec 23 '18 at 15:24
  • Hi, You have to install CoolTerm for mac. freeware.the-meiers.org – Niraj Paul Feb 25 '19 at 16:53

Not the answer you're looking for? Browse other questions tagged or ask your own question.