Arduino will not recognise USB ports on my Mac running Sierra I am a teacher who helps teachers to use LilyPad. I used to be able to plug in my LilyPad Arduino and see the USB port. I have read all the answers and dowloaded the drivers from Spark fun and another driver from Github. Nothing is working and i am not technical enough to find the answer myself. I have spent three hours today trawling through the answers to this problem and still cannot fix it myself. I am a luddite who needs a simple step by step remedy. Apple support had no idea when I rang them and told me it was an Arduino problem and to talk to them. you cant talk to anyone at Arduino you can only go to the forums. the forums tell you to read others answers before you post. I have. it's still not working. i need help. And not a lecture about being on a forum asking dumb questions.this is what I see when i look for the port

I even mucked around in terminal and am hoping it's not a 'terminal" problem because I have no clue what i am doing. If you can explain in plain speak please respond. i have to teach this stuff in 4 days. These are the drivers I downloaded.

This is the message I get when I try to upload a sketch

enter image description here

  • LilyPad USB implements a atmega32u4 with built in USB. it doesn't have any FTDI or CH340 chips. so you don't need to install the mentioned driver files. the driver for this board installs with Arduino IDE itself. if you try to reset the board with onboard switch, the ports should vanish and reappear. try this and let me know what happens. Sep 21, 2018 at 7:23
  • Tried pressing the reset button and nothing happened except the built in LED stopped flash and then returned as soon as I let the reset button go. Nothing changed in the ports. Thanks for answering. K Sep 21, 2018 at 8:52
  • interestingly the usb ports appear when i plug in an Arduino uno. but not for lilypad. Sep 21, 2018 at 9:12
  • I am a teacher who helps teachers to use LilyPad .... you should really call things by their correct names .... Arduino will not recognise USB ports on my Mac should be Arduino IDE will not recognise USB ports on my Mac
    – jsotola
    Sep 21, 2018 at 19:37

4 Answers 4


I spoke to a very clever friend who has had similar problems. The answer lay in downloading the FTDI helper package not just the driver. If anyone else is having a similar problem the website is


I downloaded it and now my lilypad and USB port is recognised by the Arduino software.

Just in time for Thursday.

Thanks to all who tried to help.



I had a problem getting my computer (Mac Pro, OS 1.12.1 Sierra) to recognize my Arduino Leonardo and Micro boards. Tried many different fixes, nothing worked. Finally used a different cable, and both boards worked fine. NB: I didn't suspect a cable problem, since I removed the cable from a working device. Just to make things weirder, the original device I removed the cable from worked just fine when I re-installed the (supposedly defective) cable.


The Lillypad uses the ATMega32U4 chip. This is the same as the Arduino Leonardo and the Arduino Micro, and suffers the same basic issue that they both suffer from.

Basically, the USB connection is driven by the main chip, not by an interface chip as in most other Arduino boards. This gives you increased flexibility (e.g., using it as a keyboard or a mouse) and decreased cost (less components on the board), but at the additional cost of certain problems that you have to be prepared to resolve.

Because the main chip runs the USB connection that main chip must be working properly for there to even be a USB connection. With other boards that isn't the case - you can remove the main chip completely and the USB interface chip will still work. So it is perfectly possible to "kill" the board by installing a sketch on it which stops the main chip from functioning. As soon as the main chip stops functioning the USB stops functioning - and if the sketch that is installed never starts working at all then you never see a USB connection.

Sometimes it is possible to get the USB port to appear for a short period (a few seconds) by pressing the reset switch, but you have to time it right (press reset and immediately select the port in the menu, then press upload, and press reset again just before the uploading itself starts).

The sure-fire fix, though, is to erase the entire chip (along with your installed "broken" sketch) and reinstall the bootloader using the IDE's tools. You'll need either a hardware programmer (the USBASP is dirt cheap and easy to get on eBay) or another Arduino using the ArduinoISP sketch bundled with the IDE.

If you're going to do any serious work or teaching with any microcontroller-based system it's always good to have a hardware programmer available to help recover from problems, no matter what platform you're working with. Remember: if there's a way to break it, kids will find it. And do it.

  • This is a brand new out of the box lilypad board with no sketches loaded on it at all. The ports do not appear when I plug in and select "tools". This is the third one I have opened and there is nothing that works. I have tried bot USB ports. Nothing. So it isn't broken. It just won't work. Sep 21, 2018 at 9:35
  • Hmm... That is most odd. I'd suspect your USB cable. You should also check this answer: arduino.stackexchange.com/a/46122/4143
    – Majenko
    Sep 21, 2018 at 9:49
  • i checked it. it is beyond my skill set!. Thanks anyway. Three usb cords too! Sep 21, 2018 at 10:43
  • try a computer with Linux or Windows
    – Juraj
    Sep 21, 2018 at 11:00

I had the same problem: my MacBook Air registered by Arduino Board in the USB Device Tree but it was not showing up in the Ports list of the Arduino IDE. It was resolved when I changed the Privacy and Security setting for Allow Accessories to Connect. When I changed the setting to "Automatically When Unlocked" the Arduino IDE was able to recognize my board.

Route to setting: Apple Logo on top Right -> System Settings -> Privacy and Security -> (scroll down to Security) Allow Accessories to Connect.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.