I have 2 Arduino Nanos which don't output anything on any controllable pins except for RX and TX pins. I used an LED which I have tested works on the 3.3v/GND and 5.0v/GND. When I try to control the RX and TX pins (1 and 2) the LED lights up on the board and the external LED I am using to test. I am using the example "Blink" program to test it, and I've tried it on both nanos. I've tested pins 26 (serial), 5 (digital) and 15 (digital) and none output anything. Why isn't it working?

  Turns on an LED on for one second, then off for one second, repeatedly.

  This example code is in the public domain.

// Pin 13 has an LED connected on most Arduino boards.
// Pin 11 has the LED on Teensy 2.0
// Pin 6  has the LED on Teensy++ 2.0
// Pin 13 has the LED on Teensy 3.0
// give it a name:
int led = 26;

// the setup routine runs once when you press reset:
void setup() {                
  // initialize the digital pin as an output.
  pinMode(led, OUTPUT);     

// the loop routine runs over and over again forever:
void loop() {
  digitalWrite(led, HIGH);   // turn the LED on (HIGH is the voltage level)
  delay(1000);               // wait for a second
  digitalWrite(led, LOW);    // turn the LED off by making the voltage LOW
  delay(1000);               // wait for a second
  • Anything. Please paste minimal test code demonstrating the problem. Commented Feb 12, 2016 at 19:06
  • It's the same as default
    – Matthew
    Commented Feb 12, 2016 at 19:16
  • 2
    You are using a resistor with the LED? And it is .... ohm? And you connect to GND. Pin 26??? On an nano?? Commented Feb 12, 2016 at 20:14
  • 2
    the LED doesn't need a resistor - why?
    – Nick Gammon
    Commented Feb 12, 2016 at 20:29
  • 4
    @Matthew I think you are confusing pin numbering. It is digital pin #n and analog pin # not the nano physical pin #. What you call 5 and 15 are digital pin 2 and 12, Commented Feb 12, 2016 at 21:03

2 Answers 2


I've tested pins 26 (serial), 5 (digital) and 15 (digital) and none output anything.

No, the LED doesn't need a resistor ...

because I tested it with the 5v and 3.3v therefore higher voltages doesn't blow it up

Sounds to me like you have damaged your output pins. Read The care and feeding of LEDs by Mike Cook.

The LED may briefly light up, but without a resistor you are damaging both the LED and the output pin. It is no surprise then, that afterwards the pins "none output anything".

Without a limiting resistor the output driver on the Arduino is overloaded and may burn out. Whether you have damaged the LED, the pin, or both, is hard to say.

(Edited to add)

still doesn't work on pins that I haven't used ...

Can you slow down a bit?

I've tested pins 26 (serial) ...

There is no pin 26 from the IDE point of view. On the board pin 26 is A7 (analog input 7) which cannot be used for digital input/output.

Please specify exactly what pin you tried (just choose one) and stick to the Arduino number (printed on the board, eg. D05) and then show the code you used to access that pin.

According to this ... the analogue pins can be used just the same as digital pins

That page shows a Uno. You have a Nano.

See Arduino Nano - Arduino.cc. On that page:

Analog pins 6 and 7 cannot be used as digital pins.

  • Added extra stuff to address comment about "still doesn't work".
    – Nick Gammon
    Commented Feb 13, 2016 at 2:18
  • According to this, waihung.net/arduino-tip-turn-your-analog-pins-into-digital-io, the analogue pins can be used just the same as digital pins...
    – Matthew
    Commented Feb 19, 2016 at 20:45
  • See amended answer. He shows a picture of a Uno. Don't believe everything you read on the Internet. In your case you have extended what one person said about one Arduino to think it applies to every Arduino.
    – Nick Gammon
    Commented Feb 19, 2016 at 20:50
  • I've managed to half fix the problem; I can use analogue pins as digital from A0 to A5, by referencing the pins as A+num rather then their physical location. However, the IDE doesn't recognise any D+num, so I still can't use the normal digital pins...
    – Matthew
    Commented Feb 20, 2016 at 23:10
  • Digital pin 2 is just 2. For example: digitalWrite (2, HIGH); and for analog pins: digitalWrite (A3, HIGH); These are "board" pins, not the pins on the processor chip.
    – Nick Gammon
    Commented Feb 21, 2016 at 1:13

No, the LED doesn't need a resistor ...

That is correct, but the processor I/O - output pin - does. Check the schematic to see how RX /TX LEDs are connected.

  • So do the RX/TX pins have integrated resistors?
    – Matthew
    Commented Feb 19, 2016 at 20:27

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.