1

It keeps giving me this warning:

You are using a version of the Arduino IDE that is newer than available at the release of this plugin.`

Does this means I need to use a night build?

1

V2.2 is pretty old by now. As far as I recall it should work fine.

V2.2 of the Arduino eclipse plugin should work fine with the Arduino IDE version 1.5.8. What that phrase wants to say is: the plugin V2.2 was released before Arduino IDE 1.5.8 was released; as such the code can not make a statement on the compatibility.

But again V2.2 is old. We hope to release V3.0 end of February 2016

  • Doesn't the warning just mean that Eclipse might be old, not the Arduino IDE? Getting a nightly build of the IDE would make things worse, wouldn't it? – Nick Gammon Feb 22 '16 at 21:02
  • Hi Nick. IMHO The writer is referring to using the nightly of the arduino eclipse plugin (which is currently at V3) and not the "hourly" of the arduino IDE. Note that the stable release of the arduino plugin is 2.4. – jantje Feb 22 '16 at 23:04
  • To clarify your answer it should work fine - do you mean the nightly build, or that V2.2 should work fine? – Nick Gammon Feb 23 '16 at 0:15
  • V2.2 of the arduino eclipse plugin should work fine with the arduino IDE version 1.5.8. As the statement says: the plugin V2.2 was released before arduino IDE 1.5.8 was released as such I could not make a statement on the compatibilty. But again V2.2 is old. We hope to release V3.0 this week – jantje Feb 23 '16 at 11:36
  • @jantje Could you please include more details to your answer, it's fairly short right now. – Avamander Feb 23 '16 at 14:03

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.