Questions tagged [piezo]

refers to the prefix of Piezoelectricity.

7 questions with no upvoted or accepted answers
Filter by
Sorted by
Tagged with
0
votes
2answers
28 views

Including keypad library removes sound from my piezo element

I am using the keypad library to include keypad and input numbers. when a specific number is entered a sound must be made. However when I input using the serial monitor , sound is working. But when I ...
0
votes
0answers
33 views

How to stop the screeching noise that comes from buzzer?

I use sfm-27 dc 3-24v Buzzer. It sounds fine if i close the buzzer using my palm but if i doesn't close it, it will make a screeching noise. I play melody using the buzzer so the sound is important. ...
0
votes
0answers
17 views

Arduino Setup for RF Transmit and Receive, IR Receive, WS2812 LEDs and a Piezo Speaker

I am new to Arduino and microcontroller in general and just finished one Project (TonUINO - a DIY music box for kids). Now I am planing and working on my next project. A IR shooting range. The guns ...
0
votes
0answers
23 views

Shall an active piezo buzzer module draw as much as 10mA on its signal pin?

I have connected an active piezo buzzer to my arduino: KY-012 Active buzzer module. I was a bit surprised that it drew like ~10mA on the signal pin from my nodemcu, which I find a bit weird, since ...
0
votes
0answers
72 views

my button won't work, why?

I have been trying to get the button to work properly for over a day, but it just won't, can you help me. The lcd display is for another part of this project, not important at the moment, but I can't ...
0
votes
1answer
210 views

Why does analog sensor “hum” when plugged into common ground?

I have the ground for an SD card module, LED, and piezo sensor all plugged into the same ground rail. When doing this I get a low "hum" in the piezo readings where instead of reading ground voltage (0)...
-1
votes
2answers
37 views

Load Resistor Use for Voltage Sensing by Arduino

I connected a piezoelectric film to a Arduino Uno board via analog input. However, as I was getting very high voltage values (reaching 5 volts without much movement). Therefore, I added a 1 megaohm ...