Skip to main content
Share Your Experience: Take the 2024 Developer Survey

Questions tagged [lora]

The tag has no usage guidance.

Filter by
Sorted by
Tagged with
-1 votes
1 answer
59 views

Help reducing dynamic memory usage with LoRa library

I have combined code that reads heart rate and SPO2 then sends the data using LoRaWAN. Using these 2 libraries that work well by themselves LoraWAN lib | MAX30102 lib. My board is an Arduino Pro or ...
Inversionist's user avatar
1 vote
2 answers
76 views

Heltec WiFi LoRa 32 (V3) - Encode/decode packets to binary (make message shorter)

I'm using Heltec WiFi LoRa32 boards (ESP32-S3 + SX1262). Could you please help me how to encode data e.g. from temperature and humidity sensor into binary or hexadecimal form - to make the LoRa packet ...
iotdeveloper's user avatar
0 votes
1 answer
547 views

Lora SX1278 stops receiving after a short time

I am working with two Lora ra-02 sx1278 modules and two Arduino Uno. Programming on Arduino IDE 2.1.1 sender receiver The problem is the receiver receives a few packets successfully, but then the ...
Rouhi's user avatar
  • 11
0 votes
1 answer
257 views

ESP32 TTGO T-Call connect to SX1276

I have an ESP32 TTGO T-Call and I want to add a LoRa SX1276. I am new to that and I am trying to write a simple program that, when it receives a packet from a LoRa sender, sends via gsm an HTTP ...
kostas ch.'s user avatar
0 votes
1 answer
506 views

LoRa Ra-02 Module begin and beginPacket not working in Arduino Nano

Here there, recently I am testing Lora Ra-02 module I saw many videos and it is easy to set up, according to this schematic: LoRa SX1278 Module-----Arduino Nano Board 3.3V------- Gnd---------Gnd En/...
Asif Uz Zaman's user avatar
1 vote
1 answer
874 views

How to pass AT commands to LoRa from ESP32 UART?

I have connected a Reyax RYLR998 LoRa module to an ESP32's UART2, but AT commands passed through Hardware serial are not working. #define RXD2 16 #define TXD2 17 void setup() { Serial.begin(...
MrNams's user avatar
  • 129
1 vote
2 answers
123 views

compress data with 8-4-2-1-BCD-Code

Hello I would like to optimise a few values for transmission via radio (LoRa) beforehand. I have a sensor number (1-255), temperature (00.00-99.99) and humidity. (00.00-99.99) I would like to transmit ...
Tom Baires's user avatar
2 votes
1 answer
156 views

Arduino shield stacking issue

I'm having issues stacking shields on my Arduino Mega 2560. I would like to add to the mega a ethernet shield (https://store.arduino.cc/products/arduino-ethernet-shield-2) and on top of that the ...
Ayayron's user avatar
  • 21
1 vote
1 answer
206 views

Code got stuck after initialization with RFM69

I'm working on RFM69 connected to an Arduino Uno. Currently, I was able to initialize the RFM69 using the a code I modified from the internet. However, my Receiver part always encounters error. It ...
lostresearch's user avatar
2 votes
2 answers
82 views

RFM69HCW connected to Arduino Nano 33 BLE

I tried to connect my RFM69HCW to Arduino Nano 33 BLE, so that I won't be needing a logic level shifter to downgrade the voltage, since Arduino Nano is already 3.3V. Upon checking its data sheet and ...
lostresearch's user avatar
0 votes
0 answers
33 views

RFM69HCW connected to Arduino Uno

I have a prototype LoRa Daughter Board that utilizes RFM69HCW transceiver module. I found an interesting blog online that covers everything courtesy of Sparkfun. Here's the link RFM69HCW Tutorial by ...
lostresearch's user avatar
1 vote
0 answers
56 views

M5 Lora module and Nano - does not receive / transmit

I'm working on my first Arduino project using LoraWAN8688 ASR6501 M5 module. I would like one nano to send message, and another nano to receive and read it. I believe they are not sending or receiving ...
Filip Matyja's user avatar
0 votes
1 answer
831 views

LoRa recieves only 2-4 packets, then stops working

I'm working on LoRa project using [Ai-Thinker RA-01 SX1278 433MHz LoRa][1] with [sandeepmistry/arduino-LoRa][2] library. I modified LoRaReciever example so it looks like this #include <SPI.h> #...
krystof18's user avatar
  • 315
1 vote
1 answer
227 views

arduino nano with lora only runs once if connected to battery

this code works perfectly if connected with usb cable. but as soon as i connect my Arduino nano with battery (two 18650 batteries in series connected to VIN) it runs loop only once. it sends only 0 to ...
LongToeBoy's user avatar
1 vote
1 answer
195 views

Using Arduino LMIC library with EnableInterrupt

I am using the EnableInterrupt library, infact the only library that I can find that allows me to use six interrupts to wake the Arduino. However when I use it with the LMIC library (Matthijs Kooijman ...
Jaspal Singh Rathour's user avatar