Skip to main content

Questions tagged [l298n]

The tag has no usage guidance.

14 questions with no upvoted or accepted answers
Filter by
Sorted by
Tagged with
2 votes
0 answers
5k views

Difference between L298 and L298N motor driver

I was planning to buy a motor driver for my project purpose, but I don't understand which motor driver will suit my purpose. As there are two motor drivers available online. Can someone explain me the ...
Himanshuman's user avatar
2 votes
0 answers
254 views

Problem in integrating speed sensor LM393 with L298N

I am currently working on a project that has an automatic support wheel for bicycle. The mechanism of this project is when the speed sensor is detecting the RPM of the rear bicycle wheel it will ...
Rafi Ad-din's user avatar
1 vote
0 answers
146 views

Motor rotates well in one direction but runs slower in other with L298N and L293d

I connected 2 motors with an L293Nn driver. When I control it with my joystick, one motor works fine (Out 1 and 2 of driver.) It rotates in one direction and the other very smoothly. The problem ...
HexaTech's user avatar
1 vote
0 answers
260 views

l298N PWM motor control with Uno is not functioning correctly

I'm working on a self-balancing robot. The self-balancing is not the issue. The issue is that the motors don't respond as they are supposed to. I would understand if it were unable to balance, but the ...
Sergei Glimis's user avatar
1 vote
0 answers
351 views

L298N Gradual Voltage Drop

I have connected my motors to L298N and it in turn to arduino. My battery is ~18 V and i used a boost converter to get 12.99V. When I run my program on Arduino Mega, I check the output voltage from ...
Farid Hamidov's user avatar
1 vote
0 answers
1k views

Servo motors suddely stopped moving and a clicking sound can be heard

I think I might have shorted something by accident. I have just purchased the Elegoo Robot Car Kit v2.0. Putting things together was relatively easy. I also managed to run the first example, which ...
rbaleksandar's user avatar
-1 votes
1 answer
148 views

Why is my Arduino is getting power from the 5V pin?

I have an Arduino that is controlling two 6V DC motors through a L298N motor driver. The motor driver is being powered (from its Vin pin) by a 7.4V external source. I then have the 5V pin from the ...
Johnathon Bulman's user avatar
-1 votes
1 answer
285 views

L298N regulated output is greated than 5V

A few months ago I used a L298N module (actually the Velleman VMA409) and I managed to make my motors working fine. However now that I want to reuse it for another project something seems off: The ...
statox's user avatar
  • 107
-1 votes
1 answer
808 views

Using an L298N driver together with servo motors on the same arduino

I'm using an L298N driver (powered by a 12V, 1.5A adapter) on a MEGA Sensor Shield (powered by a USB cable). Everything works fine and I can control the direction and the speed of the DC motor, ...
Andrej's user avatar
  • 1
-1 votes
1 answer
1k views

PWM should be applied to ENA or IN1/IN2 for L298N board for speed control

I am new to the Arduino stuff and I am using L298N to drive two DC motors. When I searched online for sample code, I noticed that there are two types of design. One type uses analogWrite(pin, ...
roTor-roTor's user avatar
-1 votes
1 answer
52 views

Arduino connection with Arduino

I have 3 Arduino boards, let's call them be A, B, C. I'm connecting A with a bluetooth module and I'm getting the input from the bluetooth module. Now I want to send output from A using the digital ...
Arko Biswas's user avatar
-2 votes
1 answer
221 views

L298n driver with Arduino with 2 motors won't work

I connected the 12v power supply with 9v battery. The problem is that when i run 1 motor at time from any side (out 1, 2 out 3, 4) it works perfectly, but when I try to run both of them, only one will ...
nitu sahay's user avatar
-2 votes
1 answer
848 views

Using IN1/ IN2 pins for PWM instead of ENA in L298N

So basically i tried providing PWM directly to the IN1/IN2 Of L298n motor driver instead of using ENA pin i got more or less the same result Im using ESP32 with 30000Hz freq for my PWM My question is ...
Naveen Gupta's user avatar
-2 votes
1 answer
50 views

L298N Motor Driver - Code issuing "expected primary-expression before '=' token"

Programming Questions / L298N Driver - Code Issuing - " expected primary-expression before '=' token" Today at 07:20 pm Hello Arduino Community, Code is shown at bottom - please read below I've been ...
Gianni Sperduto's user avatar