Skip to main content
Share Your Experience: Take the 2024 Developer Survey

Questions tagged [error]

The tag has no usage guidance.

21 questions with no upvoted or accepted answers
Filter by
Sorted by
Tagged with
1 vote
0 answers
42 views

Arduino MEGA crashes with Ethernet shield to connect to two TCP servers

I have Arduino MEGA with Ethernet Shield and a SD card connected to a RUT950 GSM router. Then, I also have two sensors connected to the router and they run a TCP server that sends measurements ...
Marcus Barnet's user avatar
1 vote
0 answers
246 views

Getting “Open the GPS power failure” on module SIM808

I tried to get the gps coordinates with this program: #include <DFRobot_sim808.h> #include <SoftwareSerial.h> #define PIN_TX 8 #define PIN_RX 7 SoftwareSerial mySerial(PIN_RX,PIN_TX)...
Hans Ricardo Davila Acuña's user avatar
1 vote
0 answers
895 views

ESP32 WIFI error when trying to initialize WIFI after stopping and deinit WIFI driver

I have a firebeetle ESP32 board and I use VScode with platformIO. My platform is espressif32 v5.0.0 and the framework is arduino. I am currently implementing a WIFI connection as follows: bool ...
Slev1n's user avatar
  • 21
1 vote
0 answers
395 views

Unable To Upload Source Code on Arduino UNO(Windows 11)

I was trying to upload the source code of a project to the Arduino UNO and this is the error that I keep on receiving. After I closed and reopened it again, the Port option is gray. I tried everything ...
Shawn sony's user avatar
1 vote
0 answers
144 views

Motor rotates well in one direction but runs slower in other with L298N and L293d

I connected 2 motors with an L293Nn driver. When I control it with my joystick, one motor works fine (Out 1 and 2 of driver.) It rotates in one direction and the other very smoothly. The problem ...
HexaTech's user avatar
1 vote
0 answers
2k views

When i upload the code to nodeMCU this error comes I have checked libraries ,ports made enviroment for nodemcu but error always come to screen

Arduino: 1.8.7 (Windows 10), Board: "NodeMCU 1.0 (ESP-12E Module), 80 MHz, Flash, Disabled (new aborts on oom), Disabled, All SSL ciphers (most compatible), 32KB cache + 32KB IRAM (balanced), Use ...
Syed Asaad's user avatar
1 vote
0 answers
116 views

Error compiling arduino sketch to seeduino xiao for RF24 Module

I am trying to get 2 rf24 modules talking to each other. This is my first real arduino project so bear with my ignorance please. I could get them to work with 2 arduino nano but, when trying to ...
Luke's user avatar
  • 11
1 vote
0 answers
61 views

How to set maximal execution time of operation

I'm JSON deserializing output from ESP8266 in my Arduino UNO, but when it fails (for some reason every time after it deserializes successfully) the program lags for few seconds and I don't want that ...
krystof18's user avatar
  • 315
1 vote
0 answers
722 views

Using MPU6050 with ESP32 Cam- MPU Not Detected

Hi I'm trying to build a self balancing robot using my esp32 cam, but so far I haven't been able to setup my mpu6050 with it.I'm using the adafruit libraries with the given example sketches. The only ...
AfiJaabb's user avatar
  • 219
1 vote
0 answers
1k views

Wemos d1 mini code not uploading

I have a wemos d1 mini. I uploaded a code in wemos d1 mini and after that my wemos mini not working. I tried to upload another code in it even the led blink sketch and even a blank sketch but whenever ...
Talal zahid's user avatar
1 vote
0 answers
250 views

Trouble Uploading Sketch - Issues with SPISettings

Full disclosure - I'm very new to Arduino. I am probably missing something simple. However, I've scoured the internet and can't seem to figure it out. I am trying to use an Arduino Duo Wifi rev2 to ...
Barks's user avatar
  • 11
1 vote
0 answers
281 views

Temperature varations using ADS1115 and voltage divider to read 12v

I have an issue with reading battery voltages of three 12 volt batteries using an ESP-01 and an ADS1115. I have been graphing the measurements and the all of the graphs have a temperature component ...
rockfishon's user avatar
1 vote
0 answers
819 views

SN74HC595 Shift Register Issue

I'm trying to use the popular SN74HC595 Shift Register, but I think something isn't right because when the bits are submitted to the register it comes out with something similar but not the same. #...
Nathan Johnson's user avatar
1 vote
0 answers
234 views

LCD on top of SD datalogger flickers help!

I have a problem with my 16,2 with buttons lcd shield.(LCD Keypad Shield). It is connected on top of an SD dataloger. I came to the conclusion that every time the sd shield logs data and completes the ...
Paul Boutsiadis's user avatar
1 vote
0 answers
180 views

Error with AT+CIPSEND in ES8266 with arduino

I'm making simple web-server on esp8266 module connected to Arduino. And when +IPD,0,GET... I'm sending AT+CIPSEND=0,16. Then I write HELLOMYDEARFRIDE. It says : send 16 bytes recived. OK. But in ...
TheFnafException's user avatar
1 vote
0 answers
278 views

Can´t load a program into my ESP01 using an ArduinoUno

This is my problem, I´ve been trying to load a program(any program) into mi ESP01 and because I do not have the usb adapter, I decided to use my Arduino Uno to do the work. This is my first time ...
Albany Padron's user avatar
1 vote
0 answers
126 views

Serial monitor error message

I connected my ArduCam mini to es8266 board and opened serial monitor. Then this message appeared. It started to appear continuously. I used the code in examples "functions of ov2640". What does it ...
Ishara Ekanayake's user avatar
1 vote
0 answers
454 views

ESP-13 WiFi shield - "error: espcomm_upload_mem failed"

I am creating a web server with Arduino and a ESP-13 WiFi shield. The wiring is as following: Arduino UNO || ESP-13 WiFi shield 5V || .5V GND || GND TX || RX RX || ...
Sebastian Power's user avatar
0 votes
0 answers
323 views

Help with ESP32-CAM "AI THINKER" module

I'm trying to make a RC car (with a surveillance camera if possible, using the web-cam code that comes with the ESP library) using a ESP-32 CAM as a wifi module to control the car using my computer. ...
Krit Khad's user avatar
-1 votes
0 answers
9 views

LSM6DSOX OSError: [Errno 5] EIO for RP2040 Micropython

I am trying to get the IMU unit to work on my Nano RP2040. I get these same results on multiple Arduino Nano RP2040s I installed the python library into the rp2040 using the command ./mpremote.exe ...
SomeoneElse's user avatar
-1 votes
1 answer
2k views

TX, RX, ON, L LEDs were red at all time

Before seeing this error I did a project with my Uno board using a Bluetooth module. After that, when I powered the board to upload another program, 4 LEDs (L, TX, RX, ON) went red without blinking. ...
Brown's user avatar
  • 7