Questions tagged [error]

The tag has no usage guidance.

Filter by
Sorted by
Tagged with
5 votes
2 answers
122 views

Not enough memory error using OneSheeld.h

I'm a dairy farmer and I'm new to playing around with Arduino's. I created a code to send me SMS's when my equipment stops working as it should, but I run into a "Not enough memory" error. ...
FarmerChuck's user avatar
4 votes
2 answers
811 views

How are errors (not related to syntax) managed in arduino and in the AVR architecture in general?

I was just curious about how the AVR architecture manages errors that would cause a regular desktop program to crash. I'm talking about logical errors for example math problems that are undefined. ...
Coder_fox's user avatar
  • 688
4 votes
2 answers
2k views

STM32 "black pill" won't enter DFU mode reliably

I'm following the standard process to put an STM32 "black pill" (STM32F401CC) into DFU mode so that I can upload from the Arduino IDE over USB: Hold down boot0. Press and release rst. ...
NeilenMarais's user avatar
3 votes
1 answer
8k views

A fatal error occurred: Failed to connect to ESP32: Wrong boot mode detected (0x13)! The chip needs to be in download mode. [upload] Error 2

I have seen so many people complain about this same error and they were given a multitude of answers to help with this error, but nothing so far has worked for me. Everything was working fine until I ...
Bajer's user avatar
  • 31
3 votes
2 answers
562 views

Can't sync with programmer Arduino Uno

I have a weird problem, and it's probably because I'm doing something wrong. I'm quite new to Arduino. My Uno R3 (Elegoo) has been working fine for a month. It has been sitting on a bench for the past ...
Software Engineer's user avatar
2 votes
4 answers
25k views

esp32, platformio A fatal error occurred: Packet content transfer stopped (received 8 bytes) *** [upload] Error 2

When i try to upload code to the esp32 the following error shows up in the command line: A fatal error occurred: Packet content transfer stopped (received 8 bytes). I use platformio in VScode the ...
exo's user avatar
  • 57
2 votes
1 answer
5k views

'Var' does not name a type!

I don't have much experience in C++ programming. I'm getting this error 'z' does not name a type!!! which I have't seen in MATLAB or python... What's wrong??? It is so simple!!! float x=10; float ...
2012User's user avatar
  • 149
2 votes
1 answer
3k views

Error: Does not name a type [closed]

I have made a class called subjects and I have then made a subject called math. I am trying to set a classroom for math but it is giving me the error 'math' doesn't name a type. Code for the class ...
TechnicProblem's user avatar
2 votes
3 answers
2k views

WiFiClient.cpp:517 flush(): fail on fd 48, errno: 11, "No more processes" what it mean?

Hello i wrote this sketch that upload a temperature reading of a DHT22 sensor to a phpMyAdmin server in localHost, the sketch work fine, the data been upload every 5 min to the server than ESP go t ...
Damiano Miazzi's user avatar
2 votes
1 answer
2k views

Arduino Firebase connection refused error

I am making a project for school where I have to send data from a sensor to a webpage. After doing some research I decided to use a Real-Time Firebase database. Security is not really important and I ...
Luukv19's user avatar
  • 21
2 votes
1 answer
59 views

Movement and storage of servo positions via bluetooth

I am trying to program a 4DOF robotic arm (using 4 servo motors). I would like to move the servos using an Android app, by means of bluetooth (HC-05). I developed the app, in whose interface there are ...
Giammarco's user avatar
2 votes
0 answers
176 views

Arduino uno wifi rev2 error compiling sketch to board [duplicate]

I'm having an irritating situation with my Arduino Uno wifi rev2 board. I made an installation with an LCD, keypad and little servo motor. I first wrote the code for my regular Arduino Uno and ...
imkeVr's user avatar
  • 161
1 vote
4 answers
3k views

What does avrdude: Device signature = 0x000000 mean? Faulty wiring? Software issue? Incorrect tutorial?

I followed this tutorial a couple of times and when I clicked on bootloader I get this error: avrdude: Device signature = 0x000000 To see the configuration file click here. Why do I get this error (...
manarinian's user avatar
1 vote
2 answers
939 views

Arduino freezing frequently

I'm using an Arduino Nano for programing an automatic hand sanitizer that has a thermometer. But after running for some time the board freezes and only restarting can solve the issue. While checking ...
Roshan Mathews's user avatar
1 vote
1 answer
326 views

error: expected primary-expression before ',' token edit status 1 [closed]

Im using tinkercad for my robotics class and I can't seem to figure out a solution for this problem. Heres my codes: #include <LiquidCrystal.h> //LCD library #define echo 2 #define trig 3 // ...
user77041's user avatar
1 vote
1 answer
119 views

Node MCU not functioning correctly

i have a node mcu and i uploaded one example code to test it for rf signal decoding it worked. so after that i have written a code based on that and when i uploaded the code my node MCU suddenly isn't ...
rohithrathod banoth's user avatar
1 vote
1 answer
2k views

ESPTool 3-run stub fail error

I'm trying to program my NodeMCU ESP8266 ESP-12E module with AT commands. However, whenever I try and flash to my ESP8266 using ESPTool, I get a 3-run stub fail error. Can anyone tell me why I get ...
jimmyfinestein's user avatar
1 vote
1 answer
1k views

Error when compiling code NODE MCU ESP8266-12E module in Arduino ide

Here is my sketch: #include<ESP8266WiFi.h> char* ssid = "xxxxxxxx"; char* pass = "xxxxxxx"; void setup() { WiFi.begin(ssid,pass); Serial.begin(9600); while(WiFi.status()!=WL_CONNECTED) { ...
Mei's user avatar
  • 11
1 vote
2 answers
449 views

Communicating via Serial Monitor but not able to get comms via Terminal outside of Arduino IDE

I am using Arduino Nano 33 BLE. I am able to communicate via Serial Monitor within Arduino IDE, but not able to communicate via Terminal, outside of Arduino IDE. I am using Teraterm, do I need to do ...
Oscar's user avatar
  • 21
1 vote
1 answer
254 views

DFRobot GSM / GPS shield with UNO init error

Apologies, but I have little experience of Arduino etc. Has the "Sim808 init error" been resolved anywhere please? I have tried every example I can find including the ones on these ...
Bolin's user avatar
  • 11
1 vote
1 answer
105 views

Error message - Need help

I found this Haptic Headband project on YouTube (link below) and I am trying to verify the code that was given in the instructions with the Arduino IDE. However, I keep getting the message below and ...
ynava's user avatar
  • 11
1 vote
2 answers
4k views

Function declared in another file not recognized (undefined reference to)

I am making a multi-file arduino project, but the compiler can't recognize a function. I am using the arduino-cli version 0.10.0 This is the error I received undefined reference to pin_init() collect2....
Michele Cioccarelli's user avatar
1 vote
1 answer
1k views

Cannot upload to Robotdyn Mega 2560 PRO MINI? [duplicate]

I get this error trying to upload avrdude: stk500v2_ReceiveMessage(): timeout It is Robotdyn Mega 2560 PRO MINI and a Robotdyn CH340 which I have connected like this: I installed the CH340 drivers ...
joq3's user avatar
  • 111
1 vote
1 answer
2k views

Nan values in Egg Incubator

I've recently built my Arduino Incubator, which consists of a DHT22 sensor, an LCD Keypad Shield, some fans, resistors, e.t.c. I uploaded the sketch, and everything seemed fine. However, when I try ...
Lefteris Garyfalakis's user avatar
1 vote
0 answers
41 views

Arduino MEGA crashes with Ethernet shield to connect to two TCP servers

I have Arduino MEGA with Ethernet Shield and a SD card connected to a RUT950 GSM router. Then, I also have two sensors connected to the router and they run a TCP server that sends measurements ...
Marcus Barnet's user avatar
1 vote
1 answer
211 views

Arduino Output Panel Font Color Change

I am using Arduino IDE 2.0.3. When compiling code if there is an error it shows on a black background with a red font, that is hard for me to read. Can I change either the background or the font? ...
user224844's user avatar
1 vote
0 answers
242 views

Getting “Open the GPS power failure” on module SIM808

I tried to get the gps coordinates with this program: #include <DFRobot_sim808.h> #include <SoftwareSerial.h> #define PIN_TX 8 #define PIN_RX 7 SoftwareSerial mySerial(PIN_RX,PIN_TX)...
Hans Ricardo Davila Acuña's user avatar
1 vote
0 answers
844 views

ESP32 WIFI error when trying to initialize WIFI after stopping and deinit WIFI driver

I have a firebeetle ESP32 board and I use VScode with platformIO. My platform is espressif32 v5.0.0 and the framework is arduino. I am currently implementing a WIFI connection as follows: bool ...
Slev1n's user avatar
  • 21
1 vote
0 answers
389 views

Unable To Upload Source Code on Arduino UNO(Windows 11)

I was trying to upload the source code of a project to the Arduino UNO and this is the error that I keep on receiving. After I closed and reopened it again, the Port option is gray. I tried everything ...
Shawn sony's user avatar
1 vote
0 answers
141 views

Motor rotates well in one direction but runs slower in other with L298N and L293d

I connected 2 motors with an L293Nn driver. When I control it with my joystick, one motor works fine (Out 1 and 2 of driver.) It rotates in one direction and the other very smoothly. The problem ...
HexaTech's user avatar
1 vote
0 answers
2k views

When i upload the code to nodeMCU this error comes I have checked libraries ,ports made enviroment for nodemcu but error always come to screen

Arduino: 1.8.7 (Windows 10), Board: "NodeMCU 1.0 (ESP-12E Module), 80 MHz, Flash, Disabled (new aborts on oom), Disabled, All SSL ciphers (most compatible), 32KB cache + 32KB IRAM (balanced), Use ...
Syed Asaad's user avatar
1 vote
0 answers
113 views

Error compiling arduino sketch to seeduino xiao for RF24 Module

I am trying to get 2 rf24 modules talking to each other. This is my first real arduino project so bear with my ignorance please. I could get them to work with 2 arduino nano but, when trying to ...
Luke's user avatar
  • 11
1 vote
0 answers
24 views

avrdude: stk500_recv(): programmer is not responding Arduino LCD_I2C Upload problem ( port not found and ...) [duplicate]

i have problem to upload the LCD I2c Example program to Arduino UNo. the code are shown below: //YWROBOT //Compatible with the Arduino IDE 1.0 //Library version:1.1 #include <Wire.h> #include &...
Soheil Paper's user avatar
1 vote
0 answers
61 views

How to set maximal execution time of operation

I'm JSON deserializing output from ESP8266 in my Arduino UNO, but when it fails (for some reason every time after it deserializes successfully) the program lags for few seconds and I don't want that ...
krystof18's user avatar
  • 315
1 vote
0 answers
693 views

Using MPU6050 with ESP32 Cam- MPU Not Detected

Hi I'm trying to build a self balancing robot using my esp32 cam, but so far I haven't been able to setup my mpu6050 with it.I'm using the adafruit libraries with the given example sketches. The only ...
AfiJaabb's user avatar
  • 219
1 vote
0 answers
1k views

Wemos d1 mini code not uploading

I have a wemos d1 mini. I uploaded a code in wemos d1 mini and after that my wemos mini not working. I tried to upload another code in it even the led blink sketch and even a blank sketch but whenever ...
Talal zahid's user avatar
1 vote
0 answers
40 views

Uploading doesn't work on MKR1000 [duplicate]

I received the error bellow when I tried to upload any sketch on my MKR100. I uninstall/reinstall de COM drivers and the arduino IDE and nothing solve the problem. I bought another MKR1000 thinking ...
Flying_Carlos's user avatar
1 vote
0 answers
249 views

Trouble Uploading Sketch - Issues with SPISettings

Full disclosure - I'm very new to Arduino. I am probably missing something simple. However, I've scoured the internet and can't seem to figure it out. I am trying to use an Arduino Duo Wifi rev2 to ...
Barks's user avatar
  • 11
1 vote
0 answers
274 views

Temperature varations using ADS1115 and voltage divider to read 12v

I have an issue with reading battery voltages of three 12 volt batteries using an ESP-01 and an ADS1115. I have been graphing the measurements and the all of the graphs have a temperature component ...
rockfishon's user avatar
1 vote
0 answers
812 views

SN74HC595 Shift Register Issue

I'm trying to use the popular SN74HC595 Shift Register, but I think something isn't right because when the bits are submitted to the register it comes out with something similar but not the same. #...
Nathan Johnson's user avatar
1 vote
0 answers
234 views

LCD on top of SD datalogger flickers help!

I have a problem with my 16,2 with buttons lcd shield.(LCD Keypad Shield). It is connected on top of an SD dataloger. I came to the conclusion that every time the sd shield logs data and completes the ...
Paul Boutsiadis's user avatar
1 vote
0 answers
179 views

Error with AT+CIPSEND in ES8266 with arduino

I'm making simple web-server on esp8266 module connected to Arduino. And when +IPD,0,GET... I'm sending AT+CIPSEND=0,16. Then I write HELLOMYDEARFRIDE. It says : send 16 bytes recived. OK. But in ...
TheFnafException's user avatar
1 vote
0 answers
274 views

Can´t load a program into my ESP01 using an ArduinoUno

This is my problem, I´ve been trying to load a program(any program) into mi ESP01 and because I do not have the usb adapter, I decided to use my Arduino Uno to do the work. This is my first time ...
Albany Padron's user avatar
1 vote
0 answers
125 views

Serial monitor error message

I connected my ArduCam mini to es8266 board and opened serial monitor. Then this message appeared. It started to appear continuously. I used the code in examples "functions of ov2640". What does it ...
Ishara Ekanayake's user avatar
1 vote
3 answers
157 views

Not able to split string into 2 char

I am trying to split an incoming string into 2 integer values since I have to control 2 dc motors with it. The processor is node MCU and I get following error:- Com Port Reading:- WiFi connected ...
suu's user avatar
  • 85
1 vote
0 answers
454 views

ESP-13 WiFi shield - "error: espcomm_upload_mem failed"

I am creating a web server with Arduino and a ESP-13 WiFi shield. The wiring is as following: Arduino UNO || ESP-13 WiFi shield 5V || .5V GND || GND TX || RX RX || ...
Sebastian Power's user avatar
1 vote
1 answer
1k views

Using functions in header files [closed]

I want to include a function in my sketch I moved to a .h file. I did it as follows: My code: #include "header.h" void setup() { fct(); } void loop() { } My header: #include "...
Spyro 999's user avatar
0 votes
1 answer
5k views

Why is the IDE not able to find the board despite it being clearly seen and selected?

i'm having an odd problem where despite having the correct port selected 3 times i'm still getting an error as shown below: message: Arduino: 1.8.9 (Windows 10), Board: "Adafruit Feather M0, ...
yanagibashi's user avatar
0 votes
1 answer
217 views

Strange values on Serial Monitor even with matched baud rate

I am using the Adafruit Flora, connected with a Max 4466 microphone sensor. When I read values from the pin numbered 12 (which is marked as a11 for analog input on the schematic of the flora) I get ...
Arbis's user avatar
  • 1
0 votes
1 answer
132 views

The Arduino copy of example code for tone() function produces a compile error: 'tone' is not declared in this scope. How can I fix this?

It's 32-bit ARM core processor is SAM3X8E ARM Cortex-M3 CPU. Error: sketch_nov16b\sketch_nov16b.ino: In function 'void setup()': sketch_nov16b:49:43: error: 'tone' was not declared in this scope tone(...
JohnB's user avatar
  • 11