Questions tagged [error]

The tag has no usage guidance.

Filter by
Sorted by
Tagged with
0
votes
0answers
13 views

getting the error “expected unqualified-id before 'if' ”

I'm new to programming and cant seem to understand Whats going on but here is my code https://pastebin.com/W55B7RAk
1
vote
0answers
26 views

PLs help me Debug i am using arduino mega 2560 , rc522 (library working) , servo (library working) [closed]

https://drive.google.com/file/d/16Qp2kUNgmyA32UKJtOwV7nQdMlSIQyle/view?usp=sharing (.ino) Arduino File https://drive.google.com/file/d/1QjBEOfvFiWJFmaAyShyTmwxzlS0NshjT/view?usp=sharing (.txt) Text ...
1
vote
0answers
30 views

I am getting a function definition is not allowed here before token again and again here is my code [closed]

void interruptSetup() { // MAKE SURE GLOBAL INTERRUPTS ARE ENABLED } ISR (TIMER2_COMPA_vect) { // triggered when Timer2 counts to 124 cli(); ...
1
vote
1answer
48 views

Using functions in header files [closed]

I want to include a function in my sketch I moved to a .h file. I did it as follows: My code: #include "header.h" void setup() { fct(); } void loop() { } My header: #include "...
0
votes
0answers
44 views

Arduino IDE 2.0 Beta doesn't start

Yesterday i downloaded the new version of the IDE to take advantage of all the new features, but it just won't open. I tried installing it to different paths, different PC's, i deleted the ...
0
votes
0answers
29 views

Using MPU6050 with ESP32 Cam- MPU Not Detected

Hi I'm trying to build a self balancing robot using my esp32 cam, but so far I haven't been able to setup my mpu6050 with it.I'm using the adafruit libraries with the given example sketches. The only ...
1
vote
1answer
22 views

DFRobot GSM / GPS shield with UNO init error

Apologies, but I have little experience of Arduino etc. Has the "Sim808 init error" been resolved anywhere please? I have tried every example I can find including the ones on these ...
1
vote
0answers
39 views

I keep gettin the error " expecte ')' before ';'. Can someone please tell me what is wrong with my code? [closed]

int MyNumber; String msg= "What is your favorite number? "; String msg2= "Haha, Nice! "; String msg3= " I SAID, WHAT IS YOUR FAVORITE NUMBER! "; void setup() { // put ...
1
vote
0answers
28 views

Help with ESP32-CAM “AI THINKER” module

I'm trying to make a RC car (with a surveillance camera if possible, using the web-cam code that comes with the ESP library) using a ESP-32 CAM as a wifi module to control the car using my computer. ...
1
vote
2answers
92 views

Arduino freezing frequently

I'm using an Arduino Nano for programing an automatic hand sanitizer that has a thermometer. But after running for some time the board freezes and only restarting can solve the issue. While checking ...
1
vote
0answers
48 views

How to fix bricked esp8266 after run AT+IPR=9600 [closed]

I was seeing tips to change baudrate to 9600, which i saw on this forum with use AT+IPR command. Unfortunately it's brick my esp8266, the indicator blue led always on. After i search google not only ...
1
vote
0answers
89 views

Wemos d1 mini code not uploading

I have a wemos d1 mini. I uploaded a code in wemos d1 mini and after that my wemos mini not working. I tried to upload another code in it even the led blink sketch and even a blank sketch but whenever ...
1
vote
0answers
115 views

can someone help me add midi output to arduino code? [closed]

so i have this program for my arduino mega 2560 and in it there is a code that runs the midi through the usb port but i wanna run it through the tx port like in this sketch: https://www.arduino.cc/en/...
0
votes
0answers
42 views

“no matching function for call to 'SimpleDHT11::read(byte*, byte*, NULL)'” error for arduino code

My code isn't working and shows up with this error message. "no matching function for call to 'SimpleDHT11::read(byte*, byte*, NULL)'" How do i fix this? This is my complete code. #include &...
3
votes
2answers
102 views

Can't sync with programmer Arduino Uno

I have a weird problem, and it's probably because I'm doing something wrong. I'm quite new to Arduino. My Uno R3 (Elegoo) has been working fine for a month. It has been sitting on a bench for the past ...
-1
votes
1answer
38 views

I get an error?

void setup() { Serial.begin(9600); pinMode(13,OUTPUT); } void loop() { if(Serial.available()>0) {s_num =Serial.read();} if(s_num=='0'){ digitalWrite(13,HIGH); delay(100); //the specified time for 0 ...
0
votes
0answers
33 views

Code not working with DHT11; the sensor returns 0 values now and before that the LED wasnt turning on

I know my code will not be great and this is very basic code, however this is my first (and last) time ever coding for a project, I have very little knowledge of code. The aim of my code is to make a ...
2
votes
1answer
36 views

Movement and storage of servo positions via bluetooth

I am trying to program a 4DOF robotic arm (using 4 servo motors). I would like to move the servos using an Android app, by means of bluetooth (HC-05). I developed the app, in whose interface there are ...
-1
votes
2answers
108 views

Arduino sketch uses too much memory storage space?

I've never used arduino before but am using one for a school project. I am using an arduino leonardo and I've uploaded the sample code below #include "Adafruit_CCS811.h" Adafruit_CCS811 ccs; ...
1
vote
1answer
62 views

Error message - Need help

I found this Haptic Headband project on YouTube (link below) and I am trying to verify the code that was given in the instructions with the Arduino IDE. However, I keep getting the message below and ...
0
votes
1answer
242 views

I get an error saying, “exit status 1 expected initializer before 'void'.”

I will be wiring a switch to the Arduino that controls the voltage. When the I turn the switch it can adjust the voltage from 0 to 5. The overall task is to print the output voltage. The print is to ...
1
vote
0answers
33 views

Uploading doesn't work on MKR1000 [duplicate]

I received the error bellow when I tried to upload any sketch on my MKR100. I uninstall/reinstall de COM drivers and the arduino IDE and nothing solve the problem. I bought another MKR1000 thinking ...
0
votes
2answers
867 views

ESPTool 3-run stub fail error

I'm trying to program my NodeMCU ESP8266 ESP-12E module with AT commands. However, whenever I try and flash to my ESP8266 using ESPTool, I get a 3-run stub fail error. Can anyone tell me why I get ...
1
vote
2answers
496 views

Function declared in another file not recognized (undefined reference to)

I am making a multi-file arduino project, but the compiler can't recognize a function. I am using the arduino-cli version 0.10.0 This is the error I received undefined reference to pin_init() collect2....
0
votes
2answers
31 views

New to Arduino and I have a WIP code for a class. ERROR with LEDs working?

(EDIT) My goal with this code is to use two potentiometers, pot0 and pot1 respectively, to control 8 leds. Pot0 controls which sequence the leds are running (1, 2, or 3) and pot1 controls which LEDs ...
1
vote
0answers
212 views

Trouble Uploading Sketch - Issues with SPISettings

Full disclosure - I'm very new to Arduino. I am probably missing something simple. However, I've scoured the internet and can't seem to figure it out. I am trying to use an Arduino Duo Wifi rev2 to ...
-2
votes
2answers
76 views

Trouble making my 12v dc motors run on my Mega 2560 Arduino [closed]

Can someone review my code to see if the code is the problem? If nothing is wrong with the code, can someone look at my image and tell me if I set up the shield and the motors wrong and see if that's ...
0
votes
1answer
182 views

Im having another problem with my code the error is "redefinition of 'AF_DCMotor motor'? [duplicate]

Heres the code #include <AFMotor.h> AF_DCMotor motor(1, MOTOR12_8KHZ); AF_DCMotor motor(2, MOTOR12_8KHZ); AF_DCMotor motor(3, MOTOR34_1KHZ); void setup() { Serial.begin(9600); Serial....
1
vote
1answer
278 views

TX,RX,ON,l LEDs were red at all time

First of all Thank you for reading my broblem.Before coming this erro I did a project in my Uno board by using a Bluetooth module.after that; when I powered the board to uploade another programe ;4 ...
1
vote
1answer
562 views

Arduino Firebase connection refused error

I am making a project for school where I have to send data from a sensor to a webpage. After doing some research I decided to use a Real-Time Firebase database. Security is not really important and I ...
0
votes
1answer
813 views

How can I fix this error “invalid operands of types 'const char [17]' and 'float' to binary 'operator+'”?

#include <Wire.h> long aX,aY,aZ,gX,gY,gZ; float rtX,rtY,rtZ,gfX,gfY,gfZ; void setup() { Serial.begin(9600); Wire.begin(); setupMPU (); } void loop() { recordAccelregisters(); ...
0
votes
1answer
24 views

program evaluating if clause incorrectly [closed]

As the title says i'm having a problem with an if clause evaluating incorrectly in one particular function uint16_t getSleepTime() { volatile uint8_t flag = EEPROM.read(3); uint8_t high ...
1
vote
0answers
136 views

Arduino uno wifi rev2 error compiling sketch to board [duplicate]

I'm having an irritating situation with my Arduino Uno wifi rev2 board. I made an installation with an LCD, keypad and little servo motor. I first wrote the code for my regular Arduino Uno and ...
-1
votes
1answer
439 views

4:1: error: expected initializer before 'void' [closed]

int button void setup() { pinMode(13, OUTPUT); pinMode(12, OUTPUT); button 4; pinMode(4=INPUT); } void loop() { if(digitalRead(4)== LOW); { digitalWrite (13, HIGH); delay (250); ...
0
votes
1answer
36 views

Serial.println Issue with Flame Sensor

I'm really new to coding and Arduino so I would be eternally grateful for the help. I'm trying to make a really basic flame sensor that beeps, lights up an LED and displays the distance from the ...
-1
votes
2answers
160 views

“'Serial' does not name a type”

I'm really new to coding and Arduino so I would be eternally grateful for the help. I'm trying to make a really basic flame sensor that beeps, lights up an LED and displays the distance from the ...
0
votes
1answer
892 views

Error when compiling code NODE MCU ESP8266-12E module in Arduino ide

Here is my sketch: #include<ESP8266WiFi.h> char* ssid = "xxxxxxxx"; char* pass = "xxxxxxx"; void setup() { WiFi.begin(ssid,pass); Serial.begin(9600); while(WiFi.status()!=WL_CONNECTED) { ...
1
vote
0answers
123 views

Temperature varations using ADS1115 and voltage divider to read 12v

I have an issue with reading battery voltages of three 12 volt batteries using an ESP-01 and an ADS1115. I have been graphing the measurements and the all of the graphs have a temperature component ...
0
votes
0answers
434 views

Getting error while compiling code [duplicate]

Arduino: 1.6.8 (Windows 7), Board: "NodeMCU 1.0 (ESP-12E Module), 80 MHz, Flash, Disabled, All SSL ciphers (most compatible), 4M (no SPIFFS), v2 Lower Memory, Disabled, None, Only Sketch, 9600" In ...
0
votes
1answer
1k views

Why is the IDE not able to find the board despite it being clearly seen and selected?

i'm having an odd problem where despite having the correct port selected 3 times i'm still getting an error as shown below: message: Arduino: 1.8.9 (Windows 10), Board: "Adafruit Feather M0, ...
1
vote
0answers
409 views

SN74HC595 Shift Register Issue

I'm trying to use the popular SN74HC595 Shift Register, but I think something isn't right because when the bits are submitted to the register it comes out with something similar but not the same. #...
0
votes
1answer
625 views

Sim800L Uploading issues, HTTPACTION returns 0, 302, 701

I'm using the Sim800L module and the NEO6M GPS Module in combination with an Arduino nano to create a simple tracking device. I get the data from the GPS and try to upload it to my site with some ...
1
vote
0answers
109 views

LCD on top of SD datalogger flickers help!

I have a problem with my 16,2 with buttons lcd shield.(LCD Keypad Shield). It is connected on top of an SD dataloger. I came to the conclusion that every time the sd shield logs data and completes the ...
1
vote
0answers
41 views

Error with AT+CIPSEND in ES8266 with arduino

I'm making simple web-server on esp8266 module connected to Arduino. And when +IPD,0,GET... I'm sending AT+CIPSEND=0,16. Then I write HELLOMYDEARFRIDE. It says : send 16 bytes recived. OK. But in ...
1
vote
0answers
193 views

Can´t load a program into my ESP01 using an ArduinoUno

This is my problem, I´ve been trying to load a program(any program) into mi ESP01 and because I do not have the usb adapter, I decided to use my Arduino Uno to do the work. This is my first time ...
0
votes
1answer
1k views

Restoring all fuse bits on AtMega328P-PU

I'm worked with Low Fuse bits in AVRDUDEPROG 3.3. Fuses was non-inverted. And by mistake I enabled SUT1 and SUT0, when SUT0 was enabled. And when I programmed avr, it shows me error that avrdude.exe: ...
1
vote
0answers
65 views

Serial monitor error message

I connected my ArduCam mini to es8266 board and opened serial monitor. Then this message appeared. It started to appear continuously. I used the code in examples "functions of ov2640". What does it ...
0
votes
1answer
79 views

Built-In Digital Map for Robot Driving

So, I'm creating this project for school. It's a simple robot with Arduino MEGA 2560 and basically, I create a digital map, feed it into the Arduino program and then the robot can drive. However, I've ...
0
votes
1answer
4k views

Arduino - “expected primary-expression before '.' token” Error

#include "Ultrasonic.h" #include <Wire.h> #include <LiquidCrystal_I2C.h> // Set the LCD address to 0x27 for a 16 chars and 2 line display LiquidCrystal_I2C lcd(0x27, 16, 2); void setup() ...
1
vote
1answer
3k views

'Var' does not name a type!

I don't have much experience in C++ programming. I'm getting this error 'z' does not name a type!!! which I have't seen in MATLAB or python... What's wrong??? It is so simple!!! float x=10; float ...