Questions tagged [atmega2560]

Low-power 8-bit AVR microcontroller with 256kB flash.

37 questions with no upvoted or accepted answers
Filter by
Sorted by
Tagged with
3
votes
0answers
75 views

Adafruit_LEDBackpack library interfering with analog input reading

I'm trying to do something I think would be simple. I'd like to read the input of a electret microphone board and update the Adafruit 24-segment LED Bar Graph. I got each individual item working ...
3
votes
1answer
226 views

How to wake up Arduino with an rtc?

I am doing a data logger with an Arduino Mega2560 and I want to use a code to make it sleep when no measure is needed and wake it up with an RTC when time comes. The reason I want this is because I ...
2
votes
0answers
105 views

Erasing all flash on boards with over 64kb of program memory

I'm using a Mega2560 board. My project needs to store some large constant data. To preserve the first 64kb flash chunk, I write these data on addresses beyond this limit. But there is either an ...
1
vote
0answers
17 views

sim808 init error when trying to use DFRobot to get gps

I'm using "mega 2650 pro" Arduino with SIM808 BK-808 V-3.1 and I connect the vcc for the sim808 to 5volt pin in the arduino, and the arduino connected with laptop usb. and I add a sim to the ...
1
vote
0answers
42 views

ISR for timer on Arduino MEGA gets called only once

I am trying to write an Arduino code to blink LED using timer 4 on Arduino MEGA (atmega2560). I resetted the timer registers, and entered all the necessary values to bring to 16MHz to 1Hz (rescalar = ...
1
vote
0answers
55 views

it just gets too hot . any way of cooling it?

there i just got started with the arduino mega2560 . i tried 8x8 matrix tube and after ~30secs i found the atmega2560 a bit hot that i can melt a small amount wax on it ! is there any sort of heatsink ...
1
vote
0answers
75 views

Arduino mega PinChangeInterrupt with 16 bit timer

With reference to this question ::I have written a program by using 16-bit timer, The program is as follows . volatile uint32_t ovfCount = 0; struct Pulse { uint32_t last_toggle; uint32_t width; ...
1
vote
0answers
37 views

Fail to burn bootloader into standalone atmega2560

I am making a project where I use standalone atmega2560. I used arduino mega schematic to put all necessary components so atmega2560 would be working. I tried to burn bootloader into it using arduino ...
1
vote
1answer
99 views

How to identify pinout of ATmega 2560 derivative board?

My 3d printer, Creality Ender 4, has an ATmega 2560 chip based card, and I need to identify the number associated with a particular Pin. I read, on the official Arduino website, a simple tutorial in ...
1
vote
0answers
65 views

CC2541 Bluetooth AT Commands not work for any Commands sended from Serial

i bought the HM 10 Bluetooth controller (CC2541), i got connect on this device through Serial Bluetooth Terminal (Android App) with Serial BLE menu this method not requires any pass and "...
1
vote
0answers
60 views

I am trying to rewrite an RFID with a MEGA2560 and a RFID-RC522

I have been trying to rewrite an RFID tag so it is the same as my other one. I have code that will read both separately but I cannot find any already written for the MEGA2560 that will work for me. ...
1
vote
0answers
85 views

Problem with I2C

I trying to make a project to write and i2c display from a renault megane vehicle. There is many people showing it but there is no code that i can use. So i buy a cheap analyzer and i can clearly see ...
1
vote
0answers
52 views

Using SMS to receive password, then to choose whether to turn the relay on or off

I'm trying to use SMS messages to turn a relay on/off but before doing that i need to have a password system before allowing the user to turn the relay on/off. Basically, you have to send the password ...
1
vote
0answers
70 views

Arduino code does not function when relays are powered

I have a mega arduino, which is supposed to to power 4 relays using 4 touch sensors TTP 223, the relays are 5V coil and 220V. the arduino is powered by a 5 V adapter "mobile phone charger" and it ...
1
vote
0answers
260 views

Advice needed for powering Multiple HX711 with Arduino Mega

I have a project where I need to use multiple load cells (6-8), with individual HX711 for each load cell, which need to be powered simultaneously. I am not sure if I can power all the HX711 with 5V ...
1
vote
0answers
73 views

MEGA2560 only starts program after pressing RESET button multiple times

I am working on a program where I am controlling an MP3 player by using UART between my MEGA2560 and the MP3 player. The MEGA2560 sends serial commands to the MP3 player when external interrupts are ...
1
vote
0answers
37 views

Min/Max current for supply input of mega2560

What is the min and max current the mega2560 can take for the 5v supply input voltage of the chip itself, not just the arduino mega?
1
vote
0answers
180 views

EEPROM.read data not comparing with DHT11 sensor value - Arduino temp controller

I'm using a DHT11 to read temperature to control a relay that will control a fan. When 'A' is pressed it allows the user to update the temp value that the relay will go HIGH at. The value is being ...
1
vote
0answers
131 views

Sketch works on MEGA 2560 timer2, but does not work on timer1

I set the PWM frequency on MEGA 2560 like this: TCCR2A = 0; TCCR2B = 0; TCNT2 = 0; TCCR2A = _BV(COM2A1) | _BV(COM2B1) | _BV(WGM20); ...
1
vote
0answers
516 views

How to program an SSD1322 display?

I'm new to programming. I would like to change the characters on an SSD1322 OLED display. Here are the photos. Is this possible with an Arduino Uno? Is the program of the display in the display or in ...
1
vote
0answers
216 views

Intermittent wifi/hotspot connection

I have an Arduino Mega 2560 with a cc3000 Wifi shield that is sending messages to dweet.io. Here is the relevant portion of my code: // Post data to dweetio char data[125]; sprintf(data, "?t1=...
1
vote
0answers
114 views

Arduino not responding while trying to flash over BLE

I'm working on wireless uploader for Arduino from iOS devices. I'm using HM-10 BLE module which seems to work ok. PIO 2 is used as DTR for resetting (see A [0x41] T [0x54] + [0x2B] P [0x50] I [0x49] O ...
1
vote
2answers
163 views

Is an atmega 2560 board compatible with the Adafruit Trellis?

I want to build a custom midi controller for my computer, and yes, Adafruit has a mini Untz project. For my purposes, I need more analog inputs than the Leonardo, and the only other option I can find ...
1
vote
1answer
305 views

Did I just brick my ATMEGA 2560?

I bought an ATMEGA2560 on eBay and programmed it with Arduino IDE 1.6.9 using the USB cable, and the LED blinked as expected - All well and good. Now I wanted to program the mega from my UNO as ...
0
votes
0answers
32 views

Interrupt keeps firing

I have wired up a 6502 to run a program, and to check what is happening on address and databus, I have built a monitor setup with an Arduino Mega2560. The monitor should read from the buses, each time ...
0
votes
0answers
41 views

Upload of software working unreliably

I've got a new Keyestudio ATmega2560 (compatible with Arduino Mega 2560) board and was trying to upload a simple sketch. I noticed that both the Arduino IDE and PlatformIO were unable to do so, they ...
0
votes
0answers
26 views

Using 433 MHz transmitter and receiver pair on a single Arduino Mega 2560

Folks, Is there a method available to set the 433 MHz transmitter to keep sending a message and the receiver to receive the message on the same Arduino Mega 2560? I saw an answer elsewhere with the ...
0
votes
0answers
92 views

RF 433MHz Sniffer

Folks, I am trying to compile and load the "RCSwitch : ReceiveDemo_Advanced". When compiled, it comes up with an error message Output was not declared in this scope. There is an "output....
0
votes
0answers
36 views

Sending array of bytes using serial communication from Mega 2560 to ESP 8266

The array is 16 analog inputs, till now these inputs are not connected to anything so they are random, except the first three elements of the array, connected to GND, in order to see the beginning of ...
0
votes
0answers
95 views

Atmega 2560 IR receiver returning random values with using NeoPixels

I am using atmega 2560 to control 590 LED lights with NeoPixels library. I also got an IR receiver connected so I could control the LED properties and it does work but only when the LEDs are not ...
0
votes
1answer
48 views

Activating a defined macro in a class from main.cpp

Sorry if this question been asked. I'm trying to activate certain function in a class using a macro defined in the class from main.cpp. I'm using jrowberg MPU6050 library if that matters. main.cpp #...
0
votes
0answers
859 views

OneWire with DS18B20 digital sensor only works on the I2C (20 and 21) pins of my Mega?

I am using an Arduino Mega to read a DS18B20 temperature sensor using the OneWire library in the code below which I got here: #include <OneWire.h> #define DS18S20_Pin 20 //DS18S20 Signal pin ...
0
votes
1answer
2k views

How to program the Robotdyn Mega 2560 PRO MINI?

I want to program the Robotdyn Mega 2560 PRO MINI which has no USB port. How do I connect the pins to an FTDI? Which setting do I have to use in the Arduino IDE?
0
votes
0answers
553 views

How to use watchdog timer for the purpose of recovery from failures in Arduino ATmega2560

Here is my tool-set; Visual Studio with plugin called "Visual Micro" Flashing the HEX file using Atmel Studio. via AVRISP mkII on ATmega 2560 MCU And my simple trial code (I have also some others). ...
0
votes
0answers
62 views

Is there an easy way to connect and control 3 servos?

I need to connect and control three Parallax Standard Servos to an Arduino board, and apart from the USB connection, nothing else will be connected to the board. My predecessor used a setup of and ...
0
votes
1answer
66 views

Which board's bootloader is on the microcontroller?

Currently I'm doing a project that needs an Atmega2560 standalone MCU. After I burned the bootloader with this method: http://www.gammon.com.au/bootloader . I set the Board as "Arduino/Genuino Mega or ...
0
votes
1answer
58 views

Value appears to change sign suddenly

When slot == SLOT_1 is true, speed_value is positive but when slot == SLOT_2 is true, speed_value becomes negative. I printed the value of speed_value immediately after the statement speed_value = -...