Skip to main content
Share Your Experience: Take the 2024 Developer Survey

Questions tagged [arduino-cli]

Arduino CLI is an all-in-one solution that provides builder, boards/library manager, uploader, discovery and many other tools needed to use any Arduino compatible board and platforms.

Filter by
Sorted by
Tagged with
-1 votes
0 answers
29 views

How to send a binary file to a Nano board through an ISP connection using Arduino CLI?

I need to send a .bin File for it to be consumed by InternalStorage from Arduino OTA library. I tried to use Arduino CLIs upload command like arduino-cli upload -i new_version.ino.bin -p AVRISP mkII -...
Andrew's Quest's user avatar
2 votes
1 answer
326 views

How to find out all #define used by arduino-cli in compile?

How to find out all #define used by arduino-cli in compile? I had seen something some time ago, but I cannot find it again. I think that it was some option somewhere, and the result was that the ...
gilhad's user avatar
  • 1,420
1 vote
0 answers
489 views

Functions downgraded in the I2S library using an ESP32

I am following the instruction to setup a microphone with an esp32 with arduino cli. Here is the tutorial https://dronebotworkshop.com/esp32-i2s/#Resources https://www.youtube.com/watch?v=m-MPBjScNRk&...
ecjb's user avatar
  • 165
1 vote
1 answer
289 views

Can't install to arduino mega 2560 using arduino-cli, but can using IDE

I have a MKS GEN L v1.0 3dprinter board that works fine uploading using the IDE. But I need to install to it using the arduino-cli. For some reason, the command arduino-cli board list says that the ...
steve antwan's user avatar
3 votes
1 answer
425 views

How to change partition scheme with arduino-cli

I'm using arduino-cli to program an ESP32-S2. If I compile my sketch using the default partition scheme > arduino-cli compile -b esp32:esp32:esp32s2 sketch a lot of space is allocated for SPIFFS ...
larsb's user avatar
  • 85
5 votes
1 answer
993 views

Library not found when using the arduino-cli command (although working with the Arduino IDE)

I have a sketch which I can upload without problem with the Arduino IDE. I installed the arduino-cli Version: 0.28.0 Commit: 06fb1909 Date: 2022-10-18T15:53:04Z. I want to compile and upload a code ...
ecjb's user avatar
  • 165
1 vote
1 answer
548 views

Error while uploading the sketch to Arduino UNO using CLI

I have connected my Arduino UNO through USB to Raspberry pi 3B. I am using CLI for editing, compiling and uploading sketches > arduino-cli upload --fqbn arduino:avr:uno cli-test. However, after ...
DaSnipeKid's user avatar
3 votes
1 answer
282 views

How to install Adafruit motorshield library in arduino-cli

I need to install this library using the arduino-cli software. I don't know what name to use for the library. Using arduino-cli lib install <library_name> I have tried Adafruit_MotorShield, ...
user171780's user avatar
5 votes
3 answers
2k views

Using Arduino as a standalone compiler

I mostly program in C/C++ so I conviniently have a GCC compiler for all my compilations. I was wondering if there is a special compiler for Arduino that can be used just like the GCC Compiler? Because ...
Supragy Mishra's user avatar
6 votes
3 answers
13k views

Access serial monitor on linux cli? Using arduino-cli?

I have an arduino uno connected via USB to a raspberry pi, the raspi is accessible via ssh only. Just started a bit with arduino-cli ; I upload a sketch which reads my analog pins. How can I access ...
groovehunter's user avatar
2 votes
1 answer
573 views

Servo doesn't move if I detach it AFER the write?

So this is a bit weird, and I don't understand anything. Basically, I'm just playing with my servo. I wrote a small program, which can be found at this link: https://pastebin.pl/view/8e9c9573 (Note: ...
stfn's user avatar
  • 23
1 vote
2 answers
4k views

Function declared in another file not recognized (undefined reference to)

I am making a multi-file arduino project, but the compiler can't recognize a function. I am using the arduino-cli version 0.10.0 This is the error I received undefined reference to pin_init() collect2....
Michele Cioccarelli's user avatar