2

This may be an extremely obvious question but I don't seem able to find a definitive answer.

I have an Arduino Uno and a Sim900 GPRS/GSM shield fitted on top of it. I had I2C working on the Arduino to communicate with a Raspberry Pi, but now that I have put the shield on top I can't get the Pi to detect the Arduino. As far as I can tell the SDA and SCL pins on the Arduino aren't being used by the shield so does anyone have any idea how I go about this?

Thanks

1
  • I had a similar issue and disconnected the coupling between the shield for A4 and A5. Seemed to work. Almost as if the GSM didn't require it but it was on the i2c network
    – user16541
    Jan 20 '16 at 3:56
0

There seems to be a number of different Sim900 shields from different suppliers? I suggest you check/post the datasheet of the one you're using. If I2C works without the shield, and does not work with the shield connected , then it seems logical that there is a pin clash.

There is a good Random Nerd Tutorial on getting started with the shield on a Uno. Maybe test it out completely before connecting to the Raspberry Pi?

The Raspberry Pi is 3.3v and the Uno is 5v. You didn't mention level shifting in your question, but it may be worthwhile.

2
  • I mean thanks for the reply, but this question is nearly 6 years old lol. At this point I haven't got the faintest recollection of how I actually fixed it
    – Brae
    Jan 11 at 9:04
  • @Brae :-) No problem, I’m new to the forum and had to find some entries to contribute to to build up some points. Glad to hear your project worked out.
    – RowanP
    Jan 11 at 20:53

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.