1

I'm new to arduino. I have nexus duino robot as described in http://www.aliexpress.com/item/3WD-48mm-Omni-Wheel-Mobile-Arduino-Robot-Kit-10019/688287804.html, the shield connected with motors and support xbee.

With simple serial comm sketch, I'm able to communicate between arduino and PC if the shield not inserted, but not if I insert the shield as it seem arduino can't receive serial data (still can send data to PC tough). Someone says that the shield might be use RX TX so it interfere with serial comm.

My Questions are, is there a way to check whether the shield use RX TX? If yes, can we make it not interfere with serial comm? Could be other problem causing this serial comm problem? Thanks in advance.

  • 1
    As always, read the schematics. – Ignacio Vazquez-Abrams Mar 28 '14 at 22:38
  • 1
    Can you give us some more information about the shield, please? There is no information about it on the page you linked to. Model number or datasheet would be good. – sachleen Mar 28 '14 at 22:42
2

You really do need to provide information on the shield, there are many versions out there (and I own half of them ).

In essence, unless you are using an alternate serial port (SerialN) or software serial, then YES, your XBee will be using the same lines as your Arduino. If you are using Serial.print or Serial.write to talk to the XBee, then that is a giveaway too.

The reason for this is the XBee talks to your Arduino through the serial port, but the Arduino IDE also talks to your Arduino (for programming and Serial.print) as well. You can only do one successfully.

In answer to your second question, most likely not. It will be the XBee shield causing you your problems.

edit: I thought I would add, I actually have ONE shield that uses RX and TX but also allows for programming at the same time. This is achieved through a series resistor and (in the case of the shield) an amplifier as well.

  • I'm back with same problem and with other problem. I'll list my experience: # have to set baud rate to 38400, it's the only value that works when the shield on (no garbage). # for once, I confirm that serial comm is OK even with the shield on, I can instruct the robot to rotate with PC, was very happy and then went sleep. And because it only once it feel like a dream, it wasn't working anymore when I tried to add more instructions. # later I check the motor and realize that one of the wheels won't rotate. Are these two problems related? Please assist on how to troubleshoot these issues. – user3336008 Apr 10 '14 at 23:20
  • All wheels working fine now, just a loose plugged cable, serial comm still not working when the shield attached. @Madivad, can you give a noob tutorial on how to make the shield that use RX and TX also allow programming at the same time. Thanks in advance. – user3336008 Apr 14 '14 at 23:26

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.