0

I have an Arduino UNO which doesn't let me upload any sketch to it nor does it get detected on the computer when I connect it to the USB port. The last sketch I uploaded on the UNO had something to do with a bluetooth module interface and serial communication. After that I haven't been able to get the UNO to do anything. When I power up the UNO the RX LED and the power LED are constantly turned on. See picture: Arduino UNO with L, PWR, and RX lights powered

I searched for answers on the forum and even tried to burn bootloader using my chinese nano as an ISP. But nothing seems to work. When I plug in the UNO my computer emits a beep sound indicating that it has detected it but is still not able to recognize it.

I see something like this on Device Manager - Unknown USB Device (Device Descriptor Request Failed)

When I used my nano as an ISP to program the UNO I kept getting the error below:

avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 1 of 10: not in sync: resp=0x15
avrdude: stk500_getsync() attempt 2 of 10: not in sync: resp=0x15

avrdude: stk500_getparm(): (a) protocol error, expect=0x14, resp=0x14

avrdude: stk500_getparm(): (a) protocol error, expect=0x14, resp=0x01
avrdude: stk500_initialize(): (a) protocol error, expect=0x14, resp=0x10
avrdude: initialization failed, rc=-1
         Double check connections and try again, or use -F to override
         this check.

avrdude: stk500_disable(): unknown response=0x12
Failed chip erase: uploading error: exit status 1

I would like to know what exactly the problem with the UNO is and if there is a possible fix for it. Thanks in advance.

19
  • Change the cable. A bad cable may cause such problems.
    – tepalia
    Commented Jun 7 at 14:24
  • check your computer ... what device is being detected?
    – jsotola
    Commented Jun 7 at 15:08
  • On an UNO there are two controllers. the at328p and another one for the USB communication. ( on clones usually a CH34x ) "Unknown USB Device (Device Descriptor Request Failed)" is not the at328p's fault. But an ISP Programmer bypasses all the USB-Serial to bootloader stuff. Commented Jun 7 at 20:08
  • The linked picture is not publicly viewable and ideally it would be in the question.
    – timemage
    Commented Jun 8 at 4:22
  • I have updated the link it should be viewable now.
    – Nitish
    Commented Jun 8 at 4:28

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.