I'm trying to get the ESP8266 up and running without a FTDI chip, just my Arduino Uno. But it seems really difficult. What I did:

  • attach the ESPs VCC directly to Arduino Uno 3.3V; RX->TX; TX->RX

Result: surprisingly worked for 2 mins, however the AT commands returned ERROR sometimes. (baud rate: 9600)

  • attach the ESPs VCC to 3.3V 500mA power supply; RX->TX; TX->RX

Result: AT commands don't work anymore, nothing is displayed in the serial monitor, not even my input; red LED constantly on.

  • attach the ESPs VCC to 3.3V 500mA power supply; TX->TX; RX->RX

Result: blue LED constantly on, no response, same as before

  • change back RX/TX connection, experimenting with baud rate (300 - 115200)

Result: blue LED flashes on start, flashes when something is sent (no matter what the baud rate is), however still no output at all.

Suddenly, I was also getting this error while uploading:

ser_recv(): programmer is not responding

Detaching the TX connection solved the problem. Btw, I am also using a voltage divider between TX of the Arduino and RX of the ESP.

Afterwards, the blue LED was on constantly again, even though I haven't changed the wiring... (really weird)

To me it looks like the Arduino Serial monitor isn't sending anything, because I don't even see my input. However, the Arduino can output stuff, therefore I assume a connection between Arduino and PC is existing. Maybe it has to do with the connection between TX -> RX, but I see no shorts, just an ordinary voltage divider (100 Ohm and 200 Ohm resistors).

As you might see, I spent a lot of time trying to figure this out. I'm kind of stuck now, as I'm not sure what else to try. If you have any ideas, tips or advice please leave an answer.

Sorry for my English, it's not my native language. If you don't understand something, feel free to ask.

Hope you can help me!

  • If you don't get the answer you need or just for future reference, there is a forum dedicated to the ESP8266 that can be found here ... esp8266.com
    – Kolban
    Jun 28, 2015 at 21:02

4 Answers 4


Tx and Rx should be crossed; meaning connect Arduino Tx to ESP Rx and vice versa.

Your second (and first) attempts are correct. Use 1uF capacitor between Vcc and Gnd. This will provide a more robust connection since the ESP can draw too much current which might cause it to reset.

When using external power supply, hook together the Arduino Gnd to the PS Gnd.

If you get "Programmer is not responding" - disconnect and reconnect the Arduino USB. Also, you shouldn't get this at all since you are not trying to program the Arduino, just use its FTDI as proxy to the ESP. Any serial terminal application can do it (you don't have to use the built-in terminal in Arduino IDE).


When the 8266 is powered from the Arduino there is barely power enough for sending. So there will be power glitches that makes the USB port inactive. Even a short voltage drop seems to disable the USB port until it is pulled and reconnected.

I struggled with this. One solution is external power for the WiFi chip. One other solution is to put a 1000 uF capacitor on the 3V power line and ground. That has worked for me.


I have powered the ESP module with 3.3V of Arduino itself.

I too used to get the error always until I changed my settings to "no line ending" at the bottom of the serial monitor.

I had kept it to "NL & CR" from other answers that I read here, and that was the reason for errors I suppose. Anyway changing it gave me the AT OK.

You should try that first.


Put CH_PD HIGH for AT mode COM.

Note if you upgrade firmware you need to take CH_PD LOW to write new firmware. Also note if you upgrade your firmware for the LUA com speed will probably default to 115200 and then SoftSerial wont work. I found it best to test on Arduino Mega as has extra serial ports.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.