1

I'm doing a project using an Arduino pro mini 3.3v and Adafruit's Neopixel. I've flashed an example (strand example) from the Adafruit Neopixel's library sketch into the Arduino using the FTDI Basic Breakout 3.3v and everything went fine.

But when I disconnected the FTDI Basic Breakout from my laptop, the LEDs stop working. They light up with some different color and the animation stops.

I tried with other example sketches and everything seemed to work fine. I never experienced anything like this and I had no success searching for this issues in forums or google.

What might be the problem and how can I solve it?

Thanks!

  • How are you powering the board and the LEDs? – Ignacio Vazquez-Abrams Mar 17 '15 at 15:39
  • I've tried two solutions, both gave same results. 5v to the strip and to the Arduino on its regulated RAW pin. 3.6v (with three 1.2 NiMh batteries) to the strip and to the Arduino RAW pin. – cagnarrogna Mar 17 '15 at 15:42

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.