1

I have a problem with my Arduino Uno board, its not mounting in my linux machine but its power is On and L light is glowing. It was working before. After I tested buttons with 12V external supply. I am facing this scenario. I tried lsusb and i checked /dev/ ports also i couldn't find `ttyACM. I tried with another Arduino board and its working. I think the board is gone, I need help to fix this problem.

I thought its a bootloader problem I got new ATMEGA328p chip board is getting power on and L is blinking but port is not mounted I tried with lsusb and also ls /dev/ttyACM* with no result.

2

You could try to flash the formware of the USB-Controller.

General steps for Arduino R3 are:

1.Put arduino in DFU mode (The R3 does NOT reqiure soldering for that)

2.flash the firmware using

dfu-programmer atmega16u2 erase
dfu-programmer atmega16u2 flash Arduino-usbserial-atmega16u2-Uno-Rev3.hex
dfu-programmer atmega16u2 reset

The package "dfu-programmer" is most likely available for your distribution.

If you have to build it from source because your dfu-programmer does not know the atmega16u2 yet, you will need to install libusb-dev (on debian-based systems).

Useful Links for that:

https://github.com/leocadiotine/Dvorany/wiki/Resetting-your-Uno-R3%27s-default-firmware http://arduino.cc/en/Hacking/DFUProgramming8U2

A useful search term for that is arduino r3 dfu-programmer

-1

Maybe you need to "reflash" the ftdi firmware. Sorry, I'm very bad in Linux. To do this, you'll need some software and a HEX file. Check this video on Youtube.

http://www.youtube.com/watch?v=fSXZMVdO5Sg

and download the arduino_usbtoserial.hex.

If doesn't work, and if your UNO have the Atmega328p chip "DIP", try to change the Atmega328p chip in the board. Remove this chip carefully. Put another chip with the bootloader and test.

I hope this can help you.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.