I have a problem with my Arduino Uno board. It's not mounting in my Linux machine, but its power is on and the LED light is glowing. It was working before. After I tested buttons with an 12 V external supply, I am facing this scenario.

I tried lsusb and I checked /dev/ ports. Also, I couldn't find `ttyACM. I tried with another Arduino board and it's working. I think the board is gone, and I need help to fix this problem.

I thought it was a bootloader problem, and I got a new ATmega328P chip board. It is getting power on and the LED is blinking, but the port is not mounted. I tried with lsusb and also ls /dev/ttyACM* with no result.

2 Answers 2


You could try to flash the firmware of the USB controller.

General steps for Arduino R3 are:

  1. Put the Arduino in DFU mode (the R3 does not require soldering for that)

  2. Flash the firmware using:

    dfu-programmer atmega16u2 erase
    dfu-programmer atmega16u2 flash Arduino-usbserial-atmega16u2-Uno-Rev3.hex
    dfu-programmer atmega16u2 reset

    The package "dfu-programmer" is most likely available for your distribution.

If you have to build it from source, because your DFU programmer does not know the ATmega16U2 yet, you will need to install libusb-dev (on Debian-based systems).

Useful links for that:

A useful search term for that is Arduino R3 DFU-programmer.


Maybe you need to "reflash" the FTDI firmware. Sorry, I'm very bad in Linux. To do this, you'll need some software and a HEX file. Check this video on YouTube:


And download the arduino_usbtoserial.hex file.

If it doesn't work, and if your Arduino Uno has the ATmega328P chip as DIP, try to change the ATmega328P chip in the board. Remove this chip carefully. Put another chip in with the bootloader and test.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.