2

I'm trying to upload a simple sketch to the new Wemos Lolin S3 Pro but unfortunately I can't seem to get it to work. I get the following error message:

    Connecting......................................

A fatal error occurred: Failed to connect to ESP32-S3: No serial data received.
For troubleshooting steps visit: https://docs.espressif.com/projects/esptool/en/latest/troubleshooting.html
Failed uploading: uploading error: exit status 2

The following board is causing problems: https://www.wemos.cc/en/latest/s3/s3_pro.html

It seems that there is no USB to UART chip and also no boot button. As board I selected the "LOLIN S3 Pro" in the Arduino IDE and under Platformio I had selected the "lolin_s3". I have also tried it under platformio with the following build flags but unfortunately without success:

build_flags = -DARDUINO_USB_MODE=1 -DARDUINO_USB_CDC_ON_BOOT=1

I am really perplexed what could be the cause?

Btw: I bought 3 of these boards and all 3 have the same issue.

1 Answer 1

2

OK I managed to solve it although I find its a little bit annoying it seems that you need to always set this board in download mode manually. (Press and hold boot and click reset button once).

If you are using Arduino IDE use the following options:

  • USB CDC On Boot -> Enabled
  • Upload Mode -> Hardware CDC / UART0

If you are using PlatformIO use the following build flags:

build_flags = '-DARDUINO_USB_MODE=1' '-DARDUINO_USB_CDC_ON_BOOT=1'

Also a good source: https://espressif-docs.readthedocs-hosted.com/projects/arduino-esp32/en/latest/tutorials/cdc_dfu_flash.html

This site is temporarily in read-only mode and not accepting new answers.

Not the answer you're looking for? Browse other questions tagged .